summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-03-24 07:43:45 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-03-28 11:17:00 +0200
commit21dcd20b4654f0494a1fe34cdb203f5973164500 (patch)
treeb0b0fc9f4e1174319a2a289cc91b4d1849b93410 /sys-apps
parentsys-apps/debianutils: Fetch tarball from dev.gentoo.org/~jsmolic (diff)
downloadgentoo-21dcd20b4654f0494a1fe34cdb203f5973164500.tar.gz
gentoo-21dcd20b4654f0494a1fe34cdb203f5973164500.tar.bz2
gentoo-21dcd20b4654f0494a1fe34cdb203f5973164500.zip
sys-apps/debianutils: add 5.7
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/debianutils/Manifest1
-rw-r--r--sys-apps/debianutils/debianutils-5.7.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/debianutils/Manifest b/sys-apps/debianutils/Manifest
index bee9537e68ae..542c2594ae16 100644
--- a/sys-apps/debianutils/Manifest
+++ b/sys-apps/debianutils/Manifest
@@ -1,3 +1,4 @@
DIST debianutils_4.11.2.tar.xz 158132 BLAKE2B c2a95c90b4267e3b1d61c21db562f960b4666982c488e69a757fb0a7a42e8e739d44f553edd8cf532df30c492e999920ab63ec3580479de7de5d901d75de76fc SHA512 0bd9098beee78b3c8dae839f0c29e9f142cbb22f2ced473cf7ae47a14d9493ba882c1829eba213780392a87a3223b3689729754c8ded80a091efaef3f6f903fd
DIST debianutils_5.4.orig.tar.xz 103640 BLAKE2B ac59ffcf7ef9523a67127e5565cb87eb694a0297eb81acba53a5ca00a2f16d024e21ba1ef6eff5079194c2cc751712fe9ad5814603deeeaa05d28343ff79a409 SHA512 a5501bdc46e203bd0cf357e5c83bb556ea7294ee603498399427dd49536848e006b21967f6239c3d808c8b9653d65f28536cf388dd18b749e54a235cc9326850
DIST debianutils_5.5.orig.tar.xz 104448 BLAKE2B 707c9072ddf1fa0c61fc66f84aea26bac7bf6f31948880ad4711e89f8f4a665ae4104e998f27e53e288b3453a71876ef44038f8e954f19055ed1049eb9b9981c SHA512 230310428ee7c145c74bb666ae729754352295230f38ef4e22f7566970c5186d607cd827a5603a678815bd48d4a1eb2716f55c32494ec75eb665651da6a56e6a
+DIST debianutils_5.7.orig.tar.gz 257231 BLAKE2B 61d2e7abcd359c5dc87b7f91e510e91e1926183c15a572c7d87cf4a590dded2e2ee8c9b4e06f7f478353139870c808927575de233200ad69e084a6f971c4bd24 SHA512 79acd8885abca93842d696167171a359011c49a40f38deeb25bc94d62905f95afa3a7b2540d3bd4b0ffd363c5c48a439a1a68139a29d6c033980b019cea75d92
diff --git a/sys-apps/debianutils/debianutils-5.7.ebuild b/sys-apps/debianutils/debianutils-5.7.ebuild
new file mode 100644
index 000000000000..484f32f6c429
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-5.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="+installkernel static"
+
+PDEPEND="
+ installkernel? (
+ || (
+ sys-kernel/installkernel-gentoo
+ sys-kernel/installkernel-systemd-boot
+ )
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
+
+src_prepare() {
+ # Avoid adding po4a dependency, upstream refreshes manpages.
+ sed -i -e '/SUBDIRS/s|po4a||' Makefile.am || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ default
+}
+
+src_install() {
+ into /
+ dobin run-parts
+
+ into /usr
+ dobin ischroot
+ dosbin savelog
+
+ doman ischroot.1 run-parts.8 savelog.8
+
+ dodoc CHANGELOG
+}