summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-04 13:28:32 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-04 13:29:57 +0300
commite6b021d8c364861fd8e65d65495228ce5317afdf (patch)
treeedbbf8f05ded6c2d1a83438d9dc47d4b2967fb15 /sys-apps/pkgcore
parentdev-python/python-rtmidi: do not look for libpthread (diff)
downloadgentoo-e6b021d8c364861fd8e65d65495228ce5317afdf.tar.gz
gentoo-e6b021d8c364861fd8e65d65495228ce5317afdf.tar.bz2
gentoo-e6b021d8c364861fd8e65d65495228ce5317afdf.zip
sys-apps/pkgcore: add 0.12.16
Closes: https://bugs.gentoo.org/872116 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.16.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 5205da439d61..08ad615bc101 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1,2 +1,3 @@
DIST pkgcore-0.12.13.tar.gz 625121 BLAKE2B add4e54c9d92570f4a4e9dad1af45f7c10e4fa48a312f1dd07b24bede5bf796d523d0a8b8d069234e92db5cf64bfb2911c57e5161ebdb7325bfb336237066b73 SHA512 26267f8ac2c79408467a20decd5fa5b12c075269b3bec155f185349186d920b5273ad1666879ac59caf08af022c2395fe737e2d51f26f9674996767bfbfb9bc6
DIST pkgcore-0.12.15.tar.gz 623988 BLAKE2B cea8187ec5f02990b5501c0d1d97a1d228de58c78e2be733074f312f1d3a1016722a0a7765b8c4284381082144164f39691c1118e6f5b509e76cf86fb9c410ff SHA512 cc70b9e0afda4958d7dd3889276f3cb3eb3873c3e866c862330ca4e935e022d742bb0e218b09a0ef584a411ef4924ae45da65db9d28147263a578157dae67c7f
+DIST pkgcore-0.12.16.tar.gz 623795 BLAKE2B b591aeaa5d780f0b273d446d1bdbdf33a44d085aa4975d3c5f394820a6f479c15da7850a699c92a56cb280ee028d922551c7226801dea6f4c34620bde3859c31 SHA512 acd7c478b342349e66dfda5ed1284663037b221e39b557215d1441e8a908c845fe26e274bcfd97b1879f5792fc017437cd0fbde1cdffc5ebc595a34fa56d2589
diff --git a/sys-apps/pkgcore/pkgcore-0.12.16.ebuild b/sys-apps/pkgcore/pkgcore-0.12.16.ebuild
new file mode 100644
index 000000000000..ae393c59b8fc
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.10.0[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ # With PYTHONDONTWRITEBYTECODE=, python will try rebuild all sorts of modules.
+ # https://bugs.gentoo.org/840266
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}