summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-23 03:10:36 +0000
committerSam James <sam@gentoo.org>2023-01-23 03:10:36 +0000
commitc82ef6e0d056b9a405a64de753ebc946fe73e2cf (patch)
tree41bb788c41024f23793bc354095d61753fd26454 /sys-apps/logwatch
parentsys-process/lsof: add 4.98.0 (diff)
downloadgentoo-c82ef6e0d056b9a405a64de753ebc946fe73e2cf.tar.gz
gentoo-c82ef6e0d056b9a405a64de753ebc946fe73e2cf.tar.bz2
gentoo-c82ef6e0d056b9a405a64de753ebc946fe73e2cf.zip
sys-apps/logwatch: add 7.8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.8.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 93913ac6575a..7ed03f8262aa 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1 +1,2 @@
DIST logwatch-7.7.tar.gz 498214 BLAKE2B 8978930fe844bde372f68038f295cc62ca61f1c2b10d18f545ddcc713cb72cd01520ff0ea0869f2dff96846431a6dd9a04da1bc79817ccb590b0235f96e934da SHA512 5224013c548e60248ef2de8aeabc760d046374f54035e7e5e00bba0c6e6777eb5e7fcfd05a9f029d3d34e9d3fb8a243ed99b417961b21895cc14b881f1ad3dd4
+DIST logwatch-7.8.tar.gz 496093 BLAKE2B 35480a22077e43b70d15a00cc0a3a8297c1e57c465d6fffe7a9a68a9b4fb14ef62c1d2bcae8a4ab2d70af16451b8f0b5dba8aec29beae1012501a118915edd92 SHA512 470b45e5838014986292c65b7e95e7922fb5364d0d375d413f710968523273372e049774a25aab58a685bf0cfe999c8ffa0c2280fc29aa83b1603256659511d9
diff --git a/sys-apps/logwatch/logwatch-7.8.ebuild b/sys-apps/logwatch/logwatch-7.8.ebuild
new file mode 100644
index 000000000000..3147899cb63c
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.8.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tmpfiles
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo
+ virtual/cron
+ virtual/mta
+ virtual/mailx
+"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else (bug #100243)
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}