summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-10-06 11:38:05 +0300
committerMichał Górny <mgorny@gentoo.org>2018-10-13 21:43:56 +0200
commitcdcdbc149200748e188be96f0b23aea2a5d0e463 (patch)
treee0b7f074ebf76ed82465376cb95919bfab75fdec /sys-apps/ethq/ethq-9999.ebuild
parentdev-util/kdevelop-php: Restrict remaining tests... (diff)
downloadgentoo-cdcdbc149200748e188be96f0b23aea2a5d0e463.tar.gz
gentoo-cdcdbc149200748e188be96f0b23aea2a5d0e463.tar.bz2
gentoo-cdcdbc149200748e188be96f0b23aea2a5d0e463.zip
sys-apps/ethq: new ebuild
Displays an auto-updating per-second count of the number of packets and bytes being handled by each queue on a multi-queue NIC. Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org> Close: https://github.com/gentoo/gentoo/pull/10082
Diffstat (limited to 'sys-apps/ethq/ethq-9999.ebuild')
-rw-r--r--sys-apps/ethq/ethq-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/ethq/ethq-9999.ebuild b/sys-apps/ethq/ethq-9999.ebuild
new file mode 100644
index 000000000000..a5106e0c3579
--- /dev/null
+++ b/sys-apps/ethq/ethq-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/isc-projects/${PN}.git"
+
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Ethernet NIC Queue stats viewer"
+HOMEPAGE="https://github.com/isc-projects/ethq"
+SRC_URI=""
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # Respect FLAGS
+ sed -i -e '/CXXFLAGS/s/= -O3/+=/' \
+ -e '/LDFLAGS/s/=/+=/' Makefile || die "sed failed for Makefile"
+
+ if ! use test ; then
+ sed -i '/TARGETS/s/ethq_test//' Makefile \
+ || die "sed failed for USE flag test"
+ fi
+}
+
+src_compile() {
+ # override for ncurses[tinfo]
+ emake CXX="$(tc-getCXX)" LIBS_CURSES="$($(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_test() {
+ local driver
+ for driver in tests/* ; do
+ "${S}"/ethq_test "${driver##*/}" "${driver}" \
+ || die "test failed on ${driver}"
+ done
+}
+
+src_install() {
+ einstalldocs
+ dobin ethq
+}