summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-06 15:06:22 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-06 15:06:34 -0800
commitd7d0d98ea093bb29a81c1f9c0d27d823c61e8640 (patch)
treeebde3994d48fced6bb735eb471fe42d54e266bfc /sys-apps/busybox
parentsys-libs/libxcrypt-4.4.12: Version bump, fix USE=system (diff)
downloadgentoo-d7d0d98ea093bb29a81c1f9c0d27d823c61e8640.tar.gz
gentoo-d7d0d98ea093bb29a81c1f9c0d27d823c61e8640.tar.bz2
gentoo-d7d0d98ea093bb29a81c1f9c0d27d823c61e8640.zip
sys-apps/busybox-1.31.1-r1: Revbump, virtual/libxcrypt, fix bug #708350
Closes: https://bugs.gentoo.org/708350 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.31.1-r1.ebuild (renamed from sys-apps/busybox/busybox-1.31.1.ebuild)15
-rw-r--r--sys-apps/busybox/files/busybox-1.31.1-glibc-2.31.patch65
2 files changed, 75 insertions, 5 deletions
diff --git a/sys-apps/busybox/busybox-1.31.1.ebuild b/sys-apps/busybox/busybox-1.31.1-r1.ebuild
index c15fa90610c7..0ee063abe46c 100644
--- a/sys-apps/busybox/busybox-1.31.1.ebuild
+++ b/sys-apps/busybox/busybox-1.31.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-EAPI=6
+EAPI=7
inherit flag-o-matic savedconfig toolchain-funcs
@@ -26,14 +26,18 @@ REQUIRED_USE="pam? ( !static )"
RESTRICT="test"
COMMON_DEPEND="!static? ( selinux? ( sys-libs/libselinux ) )
- pam? ( sys-libs/pam )"
+ pam? ( sys-libs/pam )
+ virtual/libcrypt"
DEPEND="${COMMON_DEPEND}
- static? ( selinux? ( sys-libs/libselinux[static-libs(+)] ) )
+ static? (
+ virtual/libcrypt[static-libs]
+ selinux? ( sys-libs/libselinux[static-libs(+)] )
+ )
>=sys-kernel/linux-headers-2.6.39"
RDEPEND="${COMMON_DEPEND}
mdev? ( !<sys-apps/openrc-0.13 )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
busybox_config_option() {
local flag=$1 ; shift
@@ -66,6 +70,7 @@ busybox_config_enabled() {
# patches go here!
PATCHES=(
"${FILESDIR}"/${PN}-1.26.2-bb.patch
+ "${FILESDIR}"/${PN}-1.31.1-glibc-2.31.patch
# "${FILESDIR}"/${P}-*.patch
)
diff --git a/sys-apps/busybox/files/busybox-1.31.1-glibc-2.31.patch b/sys-apps/busybox/files/busybox-1.31.1-glibc-2.31.patch
new file mode 100644
index 000000000000..1cef320b2842
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.31.1-glibc-2.31.patch
@@ -0,0 +1,65 @@
+diff --git a/coreutils/date.c b/coreutils/date.c
+index 3414d38ae..4ade6abb4 100644
+--- a/coreutils/date.c
++++ b/coreutils/date.c
+@@ -279,6 +279,9 @@ int date_main(int argc UNUSED_PARAM, char **argv)
+ time(&ts.tv_sec);
+ #endif
+ }
++#if !ENABLE_FEATURE_DATE_NANO
++ ts.tv_nsec = 0;
++#endif
+ localtime_r(&ts.tv_sec, &tm_time);
+
+ /* If date string is given, update tm_time, and maybe set date */
+@@ -301,9 +304,10 @@ int date_main(int argc UNUSED_PARAM, char **argv)
+ if (date_str[0] != '@')
+ tm_time.tm_isdst = -1;
+ ts.tv_sec = validate_tm_time(date_str, &tm_time);
++ ts.tv_nsec = 0;
+
+ /* if setting time, set it */
+- if ((opt & OPT_SET) && stime(&ts.tv_sec) < 0) {
++ if ((opt & OPT_SET) && clock_settime(CLOCK_REALTIME, &ts) < 0) {
+ bb_perror_msg("can't set date");
+ }
+ }
+diff --git a/libbb/missing_syscalls.c b/libbb/missing_syscalls.c
+index 87cf59b3d..dc40d9155 100644
+--- a/libbb/missing_syscalls.c
++++ b/libbb/missing_syscalls.c
+@@ -15,14 +15,6 @@ pid_t getsid(pid_t pid)
+ return syscall(__NR_getsid, pid);
+ }
+
+-int stime(const time_t *t)
+-{
+- struct timeval tv;
+- tv.tv_sec = *t;
+- tv.tv_usec = 0;
+- return settimeofday(&tv, NULL);
+-}
+-
+ int sethostname(const char *name, size_t len)
+ {
+ return syscall(__NR_sethostname, name, len);
+diff --git a/util-linux/rdate.c b/util-linux/rdate.c
+index 70f829e7f..878375d78 100644
+--- a/util-linux/rdate.c
++++ b/util-linux/rdate.c
+@@ -95,9 +95,13 @@ int rdate_main(int argc UNUSED_PARAM, char **argv)
+ if (!(flags & 2)) { /* no -p (-s may be present) */
+ if (time(NULL) == remote_time)
+ bb_error_msg("current time matches remote time");
+- else
+- if (stime(&remote_time) < 0)
++ else {
++ struct timespec ts;
++ ts.tv_sec = remote_time;
++ ts.tv_nsec = 0;
++ if (clock_settime(CLOCK_REALTIME, &ts) < 0)
+ bb_perror_msg_and_die("can't set time of day");
++ }
+ }
+
+ if (flags != 1) /* not lone -s */