summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2021-06-28 17:24:18 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-08 13:21:17 -0400
commit8856a04fe43d87589164c5db30655640289a2f8f (patch)
treea81884a1520f43f7911af675db8bf3391ee24807 /sys-apps/bleachbit
parentnet-misc/kea: added ~arm64 keyword (diff)
downloadgentoo-8856a04fe43d87589164c5db30655640289a2f8f.tar.gz
gentoo-8856a04fe43d87589164c5db30655640289a2f8f.tar.bz2
gentoo-8856a04fe43d87589164c5db30655640289a2f8f.zip
sys-apps/bleachbit: Bump to 4.4.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/21455 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest1
-rw-r--r--sys-apps/bleachbit/bleachbit-4.4.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index 4b52ef3b9c25..aa82595ff5f5 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1 +1,2 @@
DIST bleachbit-4.2.0.tar.bz2 606223 BLAKE2B c45a11db556b9c3e3a19583bfaa633244e2ea2e374ec8b883cba486126cfb33617cd7930af79d379711980ad4b56426b39a3e68532462be1918da1386369d137 SHA512 6d43da42c6a2a328c8fb766a3f00f4511e72a00836316c279c8dc3a24468abb4c2ce909b42c568ee0b8417c08827c7cb79ae197ae693b8d6ce60faf22422effb
+DIST bleachbit-4.4.0.tar.bz2 640690 BLAKE2B 577b5498eeb25c499753468fd6d20fa398423ee0f36837069ecd3c6e32d20686bdf2e41492d8b082551ad373266f98963d900bc68042dc0715a5f509945be352 SHA512 ad117a790803dc405752a4582b735351842305603de7ea9d98b0d59d93e8f75e18d7125958c1cb907891098f79502ebe5a560191384036506ac4ea66694f93af
diff --git a/sys-apps/bleachbit/bleachbit-4.4.0.ebuild b/sys-apps/bleachbit/bleachbit-4.4.0.ebuild
new file mode 100644
index 000000000000..3b1fdfbeb132
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-4.4.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="sqlite(+)"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1 virtualx
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]')
+ )
+"
+
+distutils_enable_tests unittest
+
+# tests fail under FEATURES=usersandbox
+RESTRICT="test"
+
+python_prepare_all() {
+ if use test; then
+ # avoid tests requiring internet access
+ rm tests/Test{Chaff,Update}.py || die
+
+ # fails due to non-existent $HOME/.profile
+ rm tests/TestInit.py || die
+
+ # only applicable to Windows installer
+ rm tests/TestNsisUtilities.py || die
+
+ # these fail on upstream Travis CI as well as on Gentoo
+ sed -e "s/test_notify(self)/_&/" \
+ -i tests/TestGUI.py || die
+
+ sed -e "s/test_get_proc_swaps(self)/_&/" \
+ -i tests/TestMemory.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C po local
+}
+
+python_test() {
+ virtx emake tests
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript ${PN}.py ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ emake -C po DESTDIR="${D}" install
+
+ insinto /usr/share/bleachbit/cleaners
+ doins cleaners/*.xml
+
+ insinto /usr/share/bleachbit
+ doins data/app-menu.ui
+
+ doicon ${PN}.png
+ domenu org.${PN}.BleachBit.desktop
+}