summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/kst
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/kst')
-rw-r--r--sci-visualization/kst/Manifest2
-rw-r--r--sci-visualization/kst/files/kst-2.0.7-cfitsio-includes.patch26
-rw-r--r--sci-visualization/kst/kst-2.0.7.ebuild65
-rw-r--r--sci-visualization/kst/kst-2.0.8.ebuild67
-rw-r--r--sci-visualization/kst/metadata.xml9
5 files changed, 169 insertions, 0 deletions
diff --git a/sci-visualization/kst/Manifest b/sci-visualization/kst/Manifest
new file mode 100644
index 000000000000..ecba3567ba07
--- /dev/null
+++ b/sci-visualization/kst/Manifest
@@ -0,0 +1,2 @@
+DIST Kst-2.0.7.tar.gz 11706657 SHA256 0ef0e1e85fa90472447eb53ee560970635532d2013d200d99ebdd105bd2eecee SHA512 d68968b9d161b74c42da87a3e5d9a2ade14e4c13e61526a0ef1e53538334b806d7f28ce3717e5a8ff85802b94aa2d7551422b873df5f180782994409ebc7ce17 WHIRLPOOL 654e054ceee5bb40de3a07d1a073c7192902616b018d355faa53770ed965eaf2dc83447f828af323401099a419ba2bfabfaacf77053e2ed4c79c123586683d3d
+DIST Kst-2.0.8.tar.gz 14527129 SHA256 cefbfd3e3710771985e08f02a397ef8ab407168fa8415d2c3c5740c031af18c6 SHA512 81be1e9ef189dbf087c5626b984297d4c8f84f22fce50c4933ea467a65f8595c0254af78d55f2b2e324934346f0758b7a0cf48d06d1108026b60b7ffba1221fb WHIRLPOOL d143cd2c88e7dcff1aeb53375272cf4b7a60f546a9c8dbd76bf8c9933575ab6fbb5f7e5f82f793dbde19d523af9314eeb8efecb8e82f30b3846ebf9d222d27d1
diff --git a/sci-visualization/kst/files/kst-2.0.7-cfitsio-includes.patch b/sci-visualization/kst/files/kst-2.0.7-cfitsio-includes.patch
new file mode 100644
index 000000000000..57238f8964eb
--- /dev/null
+++ b/sci-visualization/kst/files/kst-2.0.7-cfitsio-includes.patch
@@ -0,0 +1,26 @@
+diff --git a/src/datasources/lfiio/lfiio.h b/src/datasources/lfiio/lfiio.h
+index bb6493c..8ed748c 100644
+--- a/src/datasources/lfiio/lfiio.h
++++ b/src/datasources/lfiio/lfiio.h
+@@ -18,7 +18,7 @@
+
+ #include <datasource.h>
+ #include <dataplugin.h>
+-#include <libcfitsio0/fitsio.h>
++#include <fitsio.h>
+
+ class LFIIOSource : public Kst::DataSource {
+ Q_OBJECT
+diff --git a/src/datasources/planckIDEF/planckIDEF.h b/src/datasources/planckIDEF/planckIDEF.h
+index 7fb226f..6e6d82f 100644
+--- a/src/datasources/planckIDEF/planckIDEF.h
++++ b/src/datasources/planckIDEF/planckIDEF.h
+@@ -16,7 +16,7 @@
+
+ #include <datasource.h>
+ #include <dataplugin.h>
+-#include <libcfitsio0/fitsio.h>
++#include <fitsio.h>
+
+ typedef struct {
+ QString file;
diff --git a/sci-visualization/kst/kst-2.0.7.ebuild b/sci-visualization/kst/kst-2.0.7.ebuild
new file mode 100644
index 000000000000..cf631d04cecc
--- /dev/null
+++ b/sci-visualization/kst/kst-2.0.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CMAKE_USE_DIR=${S}/cmake
+MY_PN="Kst"
+inherit cmake-utils multilib
+
+DESCRIPTION="Fast real-time large-dataset viewing and plotting tool for KDE4"
+HOMEPAGE="http://kst.kde.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +qt4 qt5 test"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RESTRICT="test"
+
+RDEPEND="
+ qt4? (
+ dev-qt/qtcore:4
+ || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )
+ dev-qt/qtopengl:4
+ dev-qt/qtsvg:4
+ )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/designer:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ sci-libs/cfitsio
+ sci-libs/getdata
+ sci-libs/gsl
+ sci-libs/netcdf-cxx:3
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:4 )
+"
+
+DOCS=( AUTHORS ChangeLog )
+PATCHES=( "${FILESDIR}/${PN}-2.0.7-cfitsio-includes.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -Dkst_install_libdir=$(get_libdir)
+ -Dkst_pch=OFF
+ -Dkst_release=$(usex debug OFF ON)
+ -Dkst_rpath=OFF
+ -Dkst_svnversion=OFF
+ $(cmake-utils_use test kst_test)
+ $(cmake-utils_use qt5 kst_qt5)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-visualization/kst/kst-2.0.8.ebuild b/sci-visualization/kst/kst-2.0.8.ebuild
new file mode 100644
index 000000000000..9282a5e698d8
--- /dev/null
+++ b/sci-visualization/kst/kst-2.0.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+MY_P=Kst-${PV}
+
+DESCRIPTION="Fast real-time large-dataset viewing and plotting tool"
+HOMEPAGE="http://kst.kde.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +qt4 qt5 test"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RESTRICT="test"
+
+RDEPEND="
+ qt4? (
+ dev-qt/designer:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ dev-qt/qtsvg:4
+ )
+ qt5? (
+ dev-qt/designer:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ sci-libs/cfitsio
+ sci-libs/getdata
+ sci-libs/gsl
+ sci-libs/netcdf-cxx:3
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:4 )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS README.kstScript )
+
+src_configure() {
+ local mycmakeargs=(
+ -Dkst_install_libdir="$(get_libdir)"
+ -Dkst_pch=OFF
+ -Dkst_release=$(usex debug OFF ON)
+ -Dkst_rpath=OFF
+ -Dkst_svnversion=OFF
+ $(cmake-utils_use test kst_test)
+ $(cmake-utils_use qt5 kst_qt5)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-visualization/kst/metadata.xml b/sci-visualization/kst/metadata.xml
new file mode 100644
index 000000000000..7d74aa46f828
--- /dev/null
+++ b/sci-visualization/kst/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">kst</remote-id>
+ <bugs-to>http://bugs.kde.org/</bugs-to>
+ </upstream>
+</pkgmetadata>