summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-22 22:36:21 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-22 22:37:50 +0200
commitb2d04b525de8e18083fd96d02b3ca700b1e64e76 (patch)
tree93bdafc3084010800f0d688e3ec1feabaf84abda /sci-physics
parentsys-cluster/ceph: unkeyword 15.2.16 for ~amd64, ~arm64, ~ppc64 (diff)
downloadgentoo-b2d04b525de8e18083fd96d02b3ca700b1e64e76.tar.gz
gentoo-b2d04b525de8e18083fd96d02b3ca700b1e64e76.tar.bz2
gentoo-b2d04b525de8e18083fd96d02b3ca700b1e64e76.zip
sci-physics/fastjet: fix USE="cgal" with versions 5.4 and up
Closes: https://bugs.gentoo.org/851912 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/fastjet/fastjet-3.4.0-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sci-physics/fastjet/fastjet-3.4.0-r1.ebuild b/sci-physics/fastjet/fastjet-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..d35057476e08
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.4.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=plugins
+PYTHON_COMPAT=( python3_{8..11} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ media-libs/freetype
+"
+
+inherit autotools docs flag-o-matic fortran-2 python-single-r1
+
+DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
+HOMEPAGE="https://fastjet.fr/"
+SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cgal examples python +plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# cgal is header-only in version 5.4 and up. We need to use the
+# special --enable-cgal-header-only argument to use these versions.
+DEPEND="
+ cgal? ( >=sci-mathematics/cgal-5.4:=[shared(+)] )
+ plugins? ( sci-physics/siscone:= )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/fortran"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-siscone.patch
+ "${FILESDIR}"/${P}-gfortran.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use cgal && \
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+
+ econf \
+ $(use_enable cgal cgal-header-only) \
+ $(use_enable plugins allplugins) \
+ $(use_enable plugins allcxxplugins) \
+ --enable-shared \
+ --enable-static=no \
+ --disable-static \
+ --disable-auto-ptr \
+ $(use_enable python pyext)
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ if use examples; then
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}