summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-09-01 12:14:18 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-05 12:35:35 +0200
commit934ca520c4d746a03e007b0b9c0fa34d5efbc447 (patch)
tree4b007278955489bcb94fdc175e80acd1281f8140 /sci-physics/lhapdf
parentdev-libs/modsecurity: Stabilize 3.0.10 arm, #913673 (diff)
downloadgentoo-934ca520c4d746a03e007b0b9c0fa34d5efbc447.tar.gz
gentoo-934ca520c4d746a03e007b0b9c0fa34d5efbc447.tar.bz2
gentoo-934ca520c4d746a03e007b0b9c0fa34d5efbc447.zip
sci-physics/lhapdf: Fix setup.py
plus fix for USE="doc" Closes: https://bugs.gentoo.org/912579 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/gentoo/pull/32548 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics/lhapdf')
-rw-r--r--sci-physics/lhapdf/files/lhapdf-6.3.0-egg.patch16
-rw-r--r--sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild (renamed from sci-physics/lhapdf/lhapdf-6.3.0-r1.ebuild)11
2 files changed, 25 insertions, 2 deletions
diff --git a/sci-physics/lhapdf/files/lhapdf-6.3.0-egg.patch b/sci-physics/lhapdf/files/lhapdf-6.3.0-egg.patch
new file mode 100644
index 000000000000..9122b8eaf7ff
--- /dev/null
+++ b/sci-physics/lhapdf/files/lhapdf-6.3.0-egg.patch
@@ -0,0 +1,16 @@
+--- a/wrappers/python/Makefile.am 2023-09-01 11:38:37.567370819 +0200
++++ b/wrappers/python/Makefile.am 2023-09-01 11:37:50.641123445 +0200
+@@ -29,10 +29,10 @@
+
+ ## Always force setup.py, it's not good at guessing what needs to rebuild
+ all-local: fix-out-of-source
+- $(PYEXT_ENV) $(PYTHON) setup.py install --install-lib=build/ --force
++ $(PYEXT_ENV) $(PYTHON) setup.py install --single-version-externally-managed --root=/ --install-lib=$(S)/build/ --force
+
+ install-exec-local:
+- $(PYEXT_ENV) $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix) --force
++ $(PYEXT_ENV) $(PYTHON) setup.py install --single-version-externally-managed --root=/ --prefix=$(DESTDIR)$(prefix) --force
+
+ uninstall-local:
+ rm -f $(DESTDIR)$(PYTHON_PATH)/lhapdf.so
+
diff --git a/sci-physics/lhapdf/lhapdf-6.3.0-r1.ebuild b/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
index b2a2781f660e..03dda6b30a7f 100644
--- a/sci-physics/lhapdf/lhapdf-6.3.0-r1.ebuild
+++ b/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DOCS_BUILDER="doxygen"
DOCS_DEPEND="
dev-texlive/texlive-bibtexextra
@@ -14,7 +14,8 @@ DOCS_DEPEND="
"
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 docs
+DISTUTILS_EXT=1
+inherit distutils-r1 docs autotools
MY_PV=$(ver_cut 1-3)
MY_PF=LHAPDF-${MY_PV}
@@ -23,6 +24,7 @@ DESCRIPTION="Les Houches Parton Density Function unified library"
HOMEPAGE="https://lhapdf.hepforge.org/"
SRC_URI="https://www.hepforge.org/downloads/lhapdf/${MY_PF}.tar.gz"
S="${WORKDIR}/${MY_PF}"
+DOCS_DIR="${S}/doc"
LICENSE="GPL-2"
SLOT="0"
@@ -38,10 +40,15 @@ BDEPEND="
RDEPEND="${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-egg.patch
+)
+
src_prepare() {
default
# Let cython reproduce this for more recent python versions
rm wrappers/python/lhapdf.cpp || die
+ eautoreconf
}
src_configure() {