summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-06 22:19:08 +0000
committerSam James <sam@gentoo.org>2023-02-06 22:19:08 +0000
commitb8d0888f0c70069afc41163d0ad578fc620cddd7 (patch)
tree53d6b10be43542eccbef210a0ad955272e52375c /sci-misc
parentdev-games/clanlib: fix build w/ gcc 12 (diff)
downloadgentoo-b8d0888f0c70069afc41163d0ad578fc620cddd7.tar.gz
gentoo-b8d0888f0c70069afc41163d0ad578fc620cddd7.tar.bz2
gentoo-b8d0888f0c70069afc41163d0ad578fc620cddd7.zip
sci-misc/lttoolbox: fix build w/ gcc 13 (or musl)
Closes: https://bugs.gentoo.org/889400 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/lttoolbox/files/lttoolbox-3.7.1-cstdint-include.patch21
-rw-r--r--sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/sci-misc/lttoolbox/files/lttoolbox-3.7.1-cstdint-include.patch b/sci-misc/lttoolbox/files/lttoolbox-3.7.1-cstdint-include.patch
new file mode 100644
index 000000000000..c9fa2fda3aca
--- /dev/null
+++ b/sci-misc/lttoolbox/files/lttoolbox-3.7.1-cstdint-include.patch
@@ -0,0 +1,21 @@
+https://github.com/apertium/lttoolbox/pull/173
+
+From 8873eb40827179c821c4979563063200e144d129 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 6 Feb 2023 22:16:49 +0000
+Subject: [PATCH] acx: Add missing <cstdint> include
+
+Needed for int32_t. Fixes build w/ musl but also likely gcc 13.
+
+Bug: https://bugs.gentoo.org/889400
+--- a/lttoolbox/acx.h
++++ b/lttoolbox/acx.h
+@@ -18,6 +18,7 @@
+ #define _ACXPARSEUTIL_
+
+ #include <lttoolbox/sorted_vector.hpp>
++#include <cstdint>
+ #include <map>
+
+ std::map<int32_t, sorted_vector<int32_t>> readACX(const char* file);
+
diff --git a/sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild b/sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild
index f06d069fc3c1..93544468e10d 100644
--- a/sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild
+++ b/sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,6 +24,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-3.7.1-bashism.patch
+ "${FILESDIR}"/${PN}-3.7.1-cstdint-include.patch
)
src_prepare() {