summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/gt-itm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/gt-itm')
-rw-r--r--sci-misc/gt-itm/Manifest2
-rw-r--r--sci-misc/gt-itm/files/gt-itm-implicits.patch111
-rw-r--r--sci-misc/gt-itm/gt-itm-19961004-r1.ebuild75
-rw-r--r--sci-misc/gt-itm/metadata.xml5
4 files changed, 193 insertions, 0 deletions
diff --git a/sci-misc/gt-itm/Manifest b/sci-misc/gt-itm/Manifest
new file mode 100644
index 000000000000..daf4db55dd8b
--- /dev/null
+++ b/sci-misc/gt-itm/Manifest
@@ -0,0 +1,2 @@
+DIST gt-itm.tar.gz 623345 SHA256 0719947bb6e3a82d0054b6d4c74f5b3615c5583d326c32e11a848dcfed861538 SHA512 e775ac475d40fc753a27fb619f262d701818190fa3be90d587f95e215610918b56b9d67783d4e7e2f55d0064e5b2d2ce911042353b29bce1e4dbcf407ff9fabc WHIRLPOOL c447323fe98b7bef85d5fda86cfa3b559208694519be17ead0d5792dc8b27349a1c2b0bbde4d8a571f609c1c1a66b33b30888165215d332e64ee28b748328bab
+DIST sgb2ns.tar.gz 50635 SHA256 902f1a3d1a57e87387dd3bd22b8fda7c1ee2830f87fa468ab775aa8feb2a22cb SHA512 77ec6fdad61f43bf078851852aa03dfea02df235a78853e477dacc8e2b94c0d8bda9772fc00d18fdaeabc419b2780c016b7a64a1a06ac0be2c8c2aa6608c06cf WHIRLPOOL ae6a0d2701c0a98eb7b059acc8760acc444ca086b4eb60e46cce4df1491012c9b1853cb1acc35c709938103a94f005c379c5bad9630b4a464af7460a3b9e3bfb
diff --git a/sci-misc/gt-itm/files/gt-itm-implicits.patch b/sci-misc/gt-itm/files/gt-itm-implicits.patch
new file mode 100644
index 000000000000..7618354469ff
--- /dev/null
+++ b/sci-misc/gt-itm/files/gt-itm-implicits.patch
@@ -0,0 +1,111 @@
+--- gt-itm/src/geog.c
++++ gt-itm/src/geog.c
+@@ -6,6 +6,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <sys/param.h> /* for NBBY */
+ #include <alloca.h>
+ #include <assert.h>
+@@ -31,6 +32,9 @@
+
+ static char geogId[]="$Id$";
+
++long fdiam(Graph *g);
++void die(s);
++
+ double
+ distance(Vertex *u, Vertex *v)
+ {
+--- gt-itm/src/ts.c
++++ gt-itm/src/ts.c
+@@ -8,6 +8,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <sys/types.h> /* for NBBY */
+ #include <alloca.h>
+ #include "gb_graph.h"
+@@ -64,6 +65,10 @@
+ return (x); }
+ */
+
++int td_OK(Vertex *snp,Vertex *dnp);
++long random(void);
++int stubs_OK(Vertex *snp0,Vertex *snp1);
++
+ /* fast diameter computation using Floyd-Warshall
+ * Returns the HOP diameter of the graph, i.e. each edge given UNIT wt.
+ * Leaves the LENGTH diameter of the graph in g->Gldiam.
+--- gt-itm/include/geog.h
++++ gt-itm/include/geog.h
+@@ -74,3 +74,8 @@
+ geo_parms* toppp, /* params for transit connectivity */
+ geo_parms* transpp, /* " " transit domains */
+ geo_parms* stubpp); /* " " stub domains */
++
++void randomize(long* a, long size, long mean, int iters);
++long idist(Vertex *u, Vertex *v);
++int printparms(char *buf,geo_parms *pp);
++int isconnected(Graph *G);
+--- gt-itm/src/edriver.c
++++ gt-itm/src/edriver.c
+@@ -35,6 +35,8 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "gb_graph.h"
+ #include "gb_save.h"
+ #include "gb_dijk.h"
+--- gt-itm/include/eval.h
++++ gt-itm/include/eval.h
+@@ -8,4 +8,7 @@
+ enum Field {Len, A, B, Hops};
+
+ void twofield_sptree(Graph*, Vertex*, enum Field, enum Field);
+-
++int finddegdist(Graph *g, int** degdist);
++void dopaths(Graph *g, enum Field f0, enum Field f1, int *rmin, int *rmax, float *ravg);
++void dodepthdist(Graph *g, int** ddist);
++int bicomp(Graph *g,int verbose);
+--- gt-itm/src/dfs.c
++++ gt-itm/src/dfs.c
+@@ -6,6 +6,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <alloca.h>
+ #include <sys/types.h>
+ #include "gb_graph.h"
+@@ -18,6 +19,8 @@
+
+ #define NBBY 8
+
++int dfs(Graph *G,int n,u_char *vis);
++
+ /* check connectivity of graph g */
+ /* uses depth-first search. */
+ isconnected(Graph *G)
+--- gt-itm/src/itm.c.orig 2010-10-12 17:11:25.748461793 +0200
++++ gt-itm/src/itm.c 2010-10-12 17:13:09.237165705 +0200
+@@ -42,6 +42,7 @@
+ #include <stdlib.h> /* for calloc(),atoi(),etc. */
+ #include <string.h> /* for strtok() */
+ #include "gb_graph.h"
++#include "gb_save.h"
+ #include "geog.h"
+
+ #define LINE 512
+@@ -55,6 +56,7 @@
+ char *delim = " \t\n", *nonestr = "<none>";
+ static char errstr[256];
+
++void die(s);
+
+ char *
+ get_geoparms(FILE * f, geo_parms * pp)
diff --git a/sci-misc/gt-itm/gt-itm-19961004-r1.ebuild b/sci-misc/gt-itm/gt-itm-19961004-r1.ebuild
new file mode 100644
index 000000000000..56b2fb092197
--- /dev/null
+++ b/sci-misc/gt-itm/gt-itm-19961004-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Routines to generate and analyze graphs using different models for internetwork topology"
+HOMEPAGE="http://www.cc.gatech.edu/fac/Ellen.Zegura/graphs.html
+ http://www.isi.edu/nsnam/ns/ns-topogen.html#gt-itm"
+SRC_URI="http://www.cc.gatech.edu/fac/Ellen.Zegura/gt-itm/gt-itm.tar.gz
+ http://www.isi.edu/nsnam/dist/sgb2ns.tar.gz"
+
+LICENSE="all-rights-reserved sgb2ns"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="mirror bindist"
+
+DEPEND="dev-util/sgb"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+S2="${WORKDIR}/sgb2ns"
+
+src_unpack() {
+ unpack sgb2ns.tar.gz
+
+ mkdir "${S}"
+ cd "${S}"
+ unpack gt-itm.tar.gz
+
+ sed -r -e '/^[[:alnum:]]+\.o:/d' \
+ -e 's|LIBS = -lm -lgb.*|LIBS = -lm -lgb|' \
+ -e 's/\$\(CC\)/& \$\(LDFLAGS\)/g' \
+ -i "${S}"/src/Makefile || die
+ sed -r -e '/^SYS = -DSYSV/d' \
+ -e 's|LIBS = -lm -lgb.*|LIBS = -lm -lgb|' \
+ -e 's/\$\(CC\)/& \$\(LDFLAGS\)/g' \
+ -i ${S2}/Makefile || die
+
+ rm -f "${S}"/lib/*
+
+ find "${S}"/sample-graphs/ -perm +111 -type f -name 'Run*' \
+ | xargs -r -n1 sed -re 's|(\.\./)+bin/||g' -i || die
+
+ sed -e 's|sys/types.h|sys/param.h|' -i "${S}"/src/geog.c || die
+ sed -e '162 s/connected $/connected \\/' -i "${S}"/src/eval.c || die
+
+ # fix implicit function declarations
+ sed -e '/stdio.h/ a\#include <stdlib.h>' \
+ -i "${S2}/sgb2comns.c" "${S2}/sgb2hierns.c" || die
+ sed -e "s/<strings.h>/<string.h>/g" \
+ -i "${S2}/sgb2hierns.c" || die
+ epatch "${FILESDIR}"/${PN}-implicits.patch
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake CFLAGS="${CFLAGS} -I../include" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" || die
+
+ cd "${S2}"
+ emake CFLAGS="${CFLAGS} -I\$(IDIR) -L\$(LDIR)" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin "${S}"/bin/* || die
+ dodoc "${S}"/README "${S}"/docs/* || die
+ cp -pPR "${S}"/sample-graphs "${D}"/usr/share/doc/${PF} || die
+
+ cd "${S2}"
+ dodoc *.tcl *.gb || die
+ newdoc README README.sgb2ns || die
+
+}
diff --git a/sci-misc/gt-itm/metadata.xml b/sci-misc/gt-itm/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/sci-misc/gt-itm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>