summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-11-01 21:28:03 +0100
committerTupone Alfredo <tupone@gentoo.org>2017-11-01 21:30:29 +0100
commitf7767454e6ac2a9eb63c5fc48e3fe8d1fe0ff1dd (patch)
tree9312445f04a4829b661387704a1fc7461a32a92a /sci-mathematics/why3-for-spark
parentgames-engines/openmw: version bump to 0.42 (diff)
downloadgentoo-f7767454e6ac2a9eb63c5fc48e3fe8d1fe0ff1dd.tar.gz
gentoo-f7767454e6ac2a9eb63c5fc48e3fe8d1fe0ff1dd.tar.bz2
gentoo-f7767454e6ac2a9eb63c5fc48e3fe8d1fe0ff1dd.zip
sci-mathematics/why3-for-spark: Enable coq tactics
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sci-mathematics/why3-for-spark')
-rw-r--r--sci-mathematics/why3-for-spark/files/why3-for-spark-2017-gentoo.patch26
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild2
2 files changed, 27 insertions, 1 deletions
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2017-gentoo.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2017-gentoo.patch
index 502f394afa2b..225d081ca7f9 100644
--- a/sci-mathematics/why3-for-spark/files/why3-for-spark-2017-gentoo.patch
+++ b/sci-mathematics/why3-for-spark/files/why3-for-spark-2017-gentoo.patch
@@ -12,3 +12,29 @@
let rec file_concat l =
match l with
+--- why3-for-spark-gpl-2017-src/src/coq-tactic/why3tac.ml4.old 2017-10-26 22:25:55.289094778 +0200
++++ why3-for-spark-gpl-2017-src/src/coq-tactic/why3tac.ml4 2017-10-26 22:26:10.719807270 +0200
+@@ -1352,7 +1352,7 @@
+ let limit =
+ { Call_provers.empty_limit with Call_provers.limit_time = timelimit } in
+ let call = Driver.prove_task ~command ~limit drv !task in
+- wait_on_call call
++ wait_on_call (ServerCall call)
+ with
+ | NotFO ->
+ if debug then Printexc.print_backtrace stderr; flush stderr;
+@@ -1399,14 +1399,8 @@
+ | StepLimitExceeded -> error "Step Limit Exceeded"
+ | HighFailure -> error ("Prover failure\n" ^ res.pr_output ^ "\n")
+
+-IFDEF COQ84 THEN
+-
+-ELSE
+-
+ let why3tac ?timelimit s = Proofview.V82.tactic (why3tac ?timelimit s)
+
+-END
+-
+ end
+
+ TACTIC EXTEND Why3
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
index c143320a492d..3fd441065140 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
@@ -46,10 +46,10 @@ src_prepare() {
src_configure() {
econf \
- --disable-coq-tactic \
--disable-pvs-libs \
--disable-isabelle-libs \
$(use_enable coq coq-libs) \
+ $(use_enable coq coq-tactic) \
$(use_enable doc) \
$(use_enable emacs emacs-compilation) \
$(use_enable gtk ide) \