summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/prng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/prng')
-rw-r--r--sci-mathematics/prng/Manifest1
-rw-r--r--sci-mathematics/prng/files/prng-3.0.2-shared.patch52
-rw-r--r--sci-mathematics/prng/metadata.xml13
-rw-r--r--sci-mathematics/prng/prng-3.0.2.ebuild30
4 files changed, 96 insertions, 0 deletions
diff --git a/sci-mathematics/prng/Manifest b/sci-mathematics/prng/Manifest
new file mode 100644
index 000000000000..53774578bc98
--- /dev/null
+++ b/sci-mathematics/prng/Manifest
@@ -0,0 +1 @@
+DIST prng-3.0.2.tar.gz 497047 SHA256 8299182b97c24b7891d74590a8a8438641a6c681ce34d6c3f7bc98a0649da48b SHA512 16addfedd16f1caf7489356770c15bde17d8ec5c66dca9fbaa52e50f850f2ab81a1af9d522bb6028ba5e279490beaf6c72060494e8a5367a7453a417a619367f WHIRLPOOL e23acec196e2fe9743ca083e2928db058c838e316581b8fcf041f83adc394bf92b5e19b8187caa2e02fca507808c00772dda651d310645396b8a76808197ad7f
diff --git a/sci-mathematics/prng/files/prng-3.0.2-shared.patch b/sci-mathematics/prng/files/prng-3.0.2-shared.patch
new file mode 100644
index 000000000000..c52929396c94
--- /dev/null
+++ b/sci-mathematics/prng/files/prng-3.0.2-shared.patch
@@ -0,0 +1,52 @@
+diff -Nur prng-3.0.2.orig/configure.ac prng-3.0.2/configure.ac
+--- prng-3.0.2.orig/configure.ac 2010-10-16 18:47:52.000000000 +0100
++++ prng-3.0.2/configure.ac 2010-10-16 18:49:16.000000000 +0100
+@@ -23,6 +23,7 @@
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
++AC_PROG_LIBTOOL
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+@@ -39,6 +40,8 @@
+ dnl Checks for library functions.
+ AC_CHECK_FUNCS(strtoul)
+
++AC_CHECK_LIB([m], [pow])
++
+ dnl Set flags for compiler
+ if test X"$GCC" = Xyes ; then
+ AC_SUBST(AM_CFLAGS,"-Wall -fomit-frame-pointer")
+diff -Nur prng-3.0.2.orig/examples/Makefile.am prng-3.0.2/examples/Makefile.am
+--- prng-3.0.2.orig/examples/Makefile.am 2010-10-16 18:47:52.000000000 +0100
++++ prng-3.0.2/examples/Makefile.am 2010-10-16 18:48:08.000000000 +0100
+@@ -1,11 +1,11 @@
+ ## Process this file with automake to produce Makefile.in
+ # $Id$
+
+-LDADD = $(top_builddir)/src/libprng.a -lm
++LDADD = $(top_builddir)/src/libprng.la -lm
+
+ INCLUDES = -I$(top_srcdir)/src
+
+-noinst_PROGRAMS = pairs tuples
++check_PROGRAMS = pairs tuples
+
+ # clean backup files
+ CLEANFILES = *~
+diff -Nur prng-3.0.2.orig/src/Makefile.am prng-3.0.2/src/Makefile.am
+--- prng-3.0.2.orig/src/Makefile.am 2010-10-16 18:47:52.000000000 +0100
++++ prng-3.0.2/src/Makefile.am 2010-10-16 18:48:08.000000000 +0100
+@@ -3,9 +3,9 @@
+
+ INCLUDES =
+
+-lib_LIBRARIES = libprng.a
++lib_LTLIBRARIES = libprng.la
+
+-libprng_a_SOURCES = \
++libprng_la_SOURCES = \
+ prng.c \
+ dicg.c \
+ eicg.c \
diff --git a/sci-mathematics/prng/metadata.xml b/sci-mathematics/prng/metadata.xml
new file mode 100644
index 000000000000..49b2825cfbec
--- /dev/null
+++ b/sci-mathematics/prng/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ The Pseudo-Random Number Generator library is a portable,
+ high-performance ANSI-C implementations of pseudorandom number
+ generators such as linear congruential, inversive congruential, and
+ explicit inversive congruential random number generators (called
+ LCG, ICG and EICG, respectively) created by Otmar Lendl. It is part
+ of the pLab project.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/prng/prng-3.0.2.ebuild b/sci-mathematics/prng/prng-3.0.2.ebuild
new file mode 100644
index 000000000000..9b4c2dc16cde
--- /dev/null
+++ b/sci-mathematics/prng/prng-3.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Pseudo-Random Number Generator library"
+HOMEPAGE="http://statmath.wu.ac.at/prng/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+PATCHES=( "${FILESDIR}"/${P}-shared.patch )
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc doc/${PN}.pdf
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}