summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/factmsieve
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/factmsieve')
-rw-r--r--sci-mathematics/factmsieve/Manifest1
-rw-r--r--sci-mathematics/factmsieve/factmsieve-76.ebuild36
-rw-r--r--sci-mathematics/factmsieve/files/factmsieve-76.patch52
-rw-r--r--sci-mathematics/factmsieve/metadata.xml8
4 files changed, 97 insertions, 0 deletions
diff --git a/sci-mathematics/factmsieve/Manifest b/sci-mathematics/factmsieve/Manifest
new file mode 100644
index 000000000000..6d42a3469386
--- /dev/null
+++ b/sci-mathematics/factmsieve/Manifest
@@ -0,0 +1 @@
+DIST factmsieve.76.zip 19563 SHA256 961db0a36acc58ebf5ce2f5ba9f952e018a9aefbc2f9f8ab8b2a425757c2e2a2 SHA512 b07b0676a635ff746b1edfaf064d27388df8f9c5c2fe1bd1e80d4c839c6e518e3a0b39a06b76f3d59c9fa3f4cc99df0831ba6309a2a7d2eb779b952a29996431 WHIRLPOOL c5d818122f5db9b744272999bb72c42eb73a35dd20ad4ce46822b7e5be2f978a6582c9c5a2402f5fc9a1db4e8ec9f5373f7b090421000f85abecec156cf97a81
diff --git a/sci-mathematics/factmsieve/factmsieve-76.ebuild b/sci-mathematics/factmsieve/factmsieve-76.ebuild
new file mode 100644
index 000000000000..892331aacc80
--- /dev/null
+++ b/sci-mathematics/factmsieve/factmsieve-76.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+DESCRIPTION="Convenient factorization helper script using msieve and ggnfs"
+HOMEPAGE="http://gladman.plushost.co.uk/oldsite/computing/factoring.php"
+SRC_URI="http://gladman.plushost.co.uk/oldsite/computing/${PN}.${PV}.zip"
+
+inherit eutils
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# I guess no one really "needs" python 2.6, but I'm a nice person
+RDEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ sci-mathematics/msieve
+ sci-mathematics/ggnfs"
+DEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.patch"
+}
+
+src_compile() { :;
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin/"
+ cp "${S}/${PN}.py" "${D}/usr/bin/${PN}" || die "Failed to install"
+ chmod +x "${D}/usr/bin/${PN}" || die
+}
diff --git a/sci-mathematics/factmsieve/files/factmsieve-76.patch b/sci-mathematics/factmsieve/files/factmsieve-76.patch
new file mode 100644
index 000000000000..c22f88606588
--- /dev/null
+++ b/sci-mathematics/factmsieve/files/factmsieve-76.patch
@@ -0,0 +1,52 @@
+--- factmsieve.py 2010-12-02 13:59:20.000000000 +0800
++++ factmsieve.py.new 2012-11-30 15:06:50.566116187 +0800
+@@ -1,3 +1,4 @@
++#!/usr/bin/env python2
+ # factmsieve.py - A Python driver for GGNFS and MSIEVE
+ #
+ # Copyright (c) 2010, Brian Gladman
+@@ -56,9 +57,12 @@
+ import time, subprocess, gzip, glob, math, tempfile, datetime
+ import atexit, threading, collections, multiprocessing, platform
+
++# need to save pwd
++CUR_DIR=os.path.realpath(os.curdir)
++
+ # Set binary directory paths
+-GGNFS_PATH = '../../bin/x64/Release/'
+-MSIEVE_PATH = '../../../msieve/build.vc10/x64/Release/'
++GGNFS_PATH = '/usr/bin/'
++MSIEVE_PATH = '/usr/bin/'
+
+ # Set the number of CPU cores and threads
+ NUM_CORES = 4
+@@ -69,7 +73,7 @@
+ # number of linear algebra threads to launch
+ LA_THREADS = NUM_CORES * THREADS_PER_CORE
+
+-USE_CUDA = True
++USE_CUDA = False
+ GPU_NUM = 0
+ MSIEVE_POLY_TIME_LIMIT = 0
+
+@@ -103,8 +107,8 @@
+
+ # default parameter files
+
+-DEFAULT_PAR_FILE = GGNFS_PATH + 'def-par.txt'
+-DEFAULT_POLSEL_PAR_FILE = GGNFS_PATH + 'def-nm-params.txt'
++DEFAULT_PAR_FILE = '/usr/share/doc/ggnfs/def-par.txt'
++DEFAULT_POLSEL_PAR_FILE = '/usr/share/doc/ggnfs/def-nm-params.txt'
+
+ # temporary files
+
+@@ -258,7 +262,8 @@
+ # write string to log(s):
+
+ def write_string_to_log(s):
+- with open(LOGNAME, 'a') as out_f:
++ # XXX hax
++ with open(CUR_DIR+'/'+LOGNAME, 'a') as out_f:
+ print(date_time_string() + s, file = out_f)
+
+ def output(s, console = True, log = True):
diff --git a/sci-mathematics/factmsieve/metadata.xml b/sci-mathematics/factmsieve/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/sci-mathematics/factmsieve/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>