summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-02 18:03:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-02 18:08:01 +0200
commitdaf66d27731db24d18b30f0cbf7018da57ed0851 (patch)
tree6824236da79213b85d9e3cd9c0bebf55cc608835 /sci-libs
parentdev-python/click-default-group: Mark ALLARCHES (diff)
downloadgentoo-daf66d27731db24d18b30f0cbf7018da57ed0851.tar.gz
gentoo-daf66d27731db24d18b30f0cbf7018da57ed0851.tar.bz2
gentoo-daf66d27731db24d18b30f0cbf7018da57ed0851.zip
Move {sci-libs → dev-python}/shapely
Shapely is really primarily a Python package, and it seems that the Python team is effectively going to maintain it going forward, so it fits more naturally in dev-python than sci-libs. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cartopy/cartopy-0.20.1-r1.ebuild4
-rw-r--r--sci-libs/cartopy/cartopy-0.20.2.ebuild2
-rw-r--r--sci-libs/shapely/Manifest2
-rw-r--r--sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch61
-rw-r--r--sci-libs/shapely/metadata.xml23
-rw-r--r--sci-libs/shapely/shapely-1.7.1-r1.ebuild31
-rw-r--r--sci-libs/shapely/shapely-1.8.2.ebuild50
7 files changed, 3 insertions, 170 deletions
diff --git a/sci-libs/cartopy/cartopy-0.20.1-r1.ebuild b/sci-libs/cartopy/cartopy-0.20.1-r1.ebuild
index d1c4f0d5d167..b160723004be 100644
--- a/sci-libs/cartopy/cartopy-0.20.1-r1.ebuild
+++ b/sci-libs/cartopy/cartopy-0.20.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,7 +26,7 @@ RDEPEND="
sci-libs/geos
dev-python/numpy[${PYTHON_USEDEP}]
sci-libs/pyshp[${PYTHON_USEDEP}]
- sci-libs/shapely[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
diff --git a/sci-libs/cartopy/cartopy-0.20.2.ebuild b/sci-libs/cartopy/cartopy-0.20.2.ebuild
index 10493288f17e..b160723004be 100644
--- a/sci-libs/cartopy/cartopy-0.20.2.ebuild
+++ b/sci-libs/cartopy/cartopy-0.20.2.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
sci-libs/geos
dev-python/numpy[${PYTHON_USEDEP}]
sci-libs/pyshp[${PYTHON_USEDEP}]
- sci-libs/shapely[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
diff --git a/sci-libs/shapely/Manifest b/sci-libs/shapely/Manifest
deleted file mode 100644
index 0145b67b8f00..000000000000
--- a/sci-libs/shapely/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST shapely-1.7.1.tar.gz 293368 BLAKE2B 14d9cb0c2b486a3a20b71c0cde7260ec357287ea020352c0320eea07b91674605bdcd22512b33c5ac5a71b89c3d811946f8dd6d3b90c61398203a4c68f30d067 SHA512 72070437960a8c1cf6504b5f4ccc8ec509f87fb6a90178e291aff14889f5add89f9ed4f7e9a19799ce0835c1aea3f0241eaa6efd4d8ea5b879f2167f7c1de50a
-DIST shapely-1.8.2.gh.tar.gz 322064 BLAKE2B f21f91eb58818aa30464c719b1079d382c5a00f13eda70c532e4a12f1612284240e5c8c110a867c74eaa4aac5f3a21fd10b23c7ce781808d4adc871d038b8b2b SHA512 c85323f180622235257aed28c85640c63bb43cbcb2bd7ed9b354a0f23a92e0ca8becf7a94e85edea3a90cfd01017ddfc6f268f4bb2945639c2cae29a73292bd6
diff --git a/sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch b/sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch
deleted file mode 100644
index 18b6c5ad9a46..000000000000
--- a/sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/tests/test_svg.py b/tests/test_svg.py
---- a/tests/test_svg.py (revision 56c0f97a80e75308cf62e0bc4883238c10f56fdf)
-+++ b/tests/test_svg.py (date 1615044742785)
-@@ -174,7 +174,8 @@
- self.assertSVG(GeometryCollection(), '<g />')
- # Valid
- self.assertSVG(
-- Point(7, 3).union(LineString([(4, 2), (8, 4)])),
-+ GeometryCollection(
-+ [Point(7, 3), LineString([(4, 2), (8, 4)])]),
- '<g><circle cx="7.0" cy="3.0" r="3.0" stroke="#555555" '
- 'stroke-width="1.0" fill="#66cc99" opacity="0.6" />'
- '<polyline fill="none" stroke="#66cc99" stroke-width="2.0" '
---- a/tests/test_wkb.py (revision 56c0f97a80e75308cf62e0bc4883238c10f56fdf)
-+++ b/tests/test_wkb.py (date 1615044817079)
-@@ -1,6 +1,11 @@
-+import binascii
-+
-+import pytest
-+
-+from shapely import wkt
- from shapely.wkb import dumps, loads
- from shapely.geometry import Point
--import binascii
-+from shapely.geos import geos_version
-
-
- def bin2hex(value):
-@@ -49,3 +54,20 @@
- # replace geometry srid with another
- result = dumps(geom, srid=27700)
- assert bin2hex(result) == "0101000020346C0000333333333333F33F3333333333330B40"
-+
-+
-+requires_geos_39 = pytest.mark.xfail(
-+ geos_version < (3, 9, 0), reason="GEOS >= 3.9.0 is required", strict=True)
-+
-+
-+@requires_geos_39
-+def test_point_empty():
-+ g = wkt.loads("POINT EMPTY")
-+ assert g.wkb_hex == "0101000000000000000000F87F000000000000F87F"
-+
-+
-+@requires_geos_39
-+def test_point_z_empty():
-+ g = wkt.loads("POINT Z EMPTY")
-+ assert g.wkb_hex == \
-+ "0101000080000000000000F87F000000000000F87F000000000000F87F"
-diff --git a/shapely/geos.py b/shapely/geos.py
---- a/shapely/geos.py (revision 56c0f97a80e75308cf62e0bc4883238c10f56fdf)
-+++ b/shapely/geos.py (date 1615044673942)
-@@ -84,7 +84,7 @@
- 'libgeos_c.so.1',
- 'libgeos_c.so',
- ]
-- _lgeos = load_dll('geos_c', fallbacks=alt_paths)
-+ _lgeos = load_dll('libgeos_c', fallbacks=alt_paths)
- # Necessary for environments with only libc.musl
- c_alt_paths = [
- 'libc.musl-x86_64.so.1'
diff --git a/sci-libs/shapely/metadata.xml b/sci-libs/shapely/metadata.xml
deleted file mode 100644
index 6432c651184e..000000000000
--- a/sci-libs/shapely/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>3dprint@gentoo.org</email>
- <name>Gentoo 3D Printer Project</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
- Shapely is a BSD-licensed Python package for manipulation and analysis of planar geometric objects.
- It is based on the widely deployed GEOS (the engine of PostGIS) and JTS (from which GEOS is ported) libraries.
- Shapely is not concerned with data formats or coordinate systems, but can be readily integrated with packages that are.
- </longdescription>
- <upstream>
- <bugs-to>https://github.com/shapely/shapely/issues</bugs-to>
- <doc>https://shapely.readthedocs.io</doc>
- <remote-id type="github">shapely/shapely</remote-id>
- <remote-id type="pypi">Shapely</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/shapely/shapely-1.7.1-r1.ebuild b/sci-libs/shapely/shapely-1.7.1-r1.ebuild
deleted file mode 100644
index 749e53b1ac3e..000000000000
--- a/sci-libs/shapely/shapely-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="https://pypi.org/project/Shapely/ https://github.com/Toblerity/Shapely"
-SRC_URI="https://github.com/Toblerity/Shapely/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-DEPEND=">=sci-libs/geos-3.9"
-RDEPEND="${DEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="${DEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-tests-support-geos-3.9.patch"
-)
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs dev-python/matplotlib
diff --git a/sci-libs/shapely/shapely-1.8.2.ebuild b/sci-libs/shapely/shapely-1.8.2.ebuild
deleted file mode 100644
index e123057db79a..000000000000
--- a/sci-libs/shapely/shapely-1.8.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="
- https://pypi.org/project/Shapely/
- https://github.com/shapely/shapely/
-"
-SRC_URI="
- https://github.com/shapely/shapely/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-DEPEND="
- >=sci-libs/geos-3.9
-"
-RDEPEND="
- ${DEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${DEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/matplotlib
-
-src_prepare() {
- rm -r _vendor || die
- sed -i -e 's:_vendor\.::' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- rm -rf shapely || die
- epytest
-}