summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-01-15 21:22:53 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-02-08 11:18:35 +0200
commitc2084424fb801979847ecab89239a0ebd7963862 (patch)
tree5b66118550a5e316767602e7c872bcb413f7c277 /sci-libs
parentsci-libs/cantera: 3.0.0-r1 to enable python-3.12 (upstream patch) (diff)
downloadgentoo-c2084424fb801979847ecab89239a0ebd7963862.tar.gz
gentoo-c2084424fb801979847ecab89239a0ebd7963862.tar.bz2
gentoo-c2084424fb801979847ecab89239a0ebd7963862.zip
sci-libs/cantera: sort RDEPEND items; drop USE check duplicate
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/34795 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cantera/cantera-2.6.0-r2.ebuild12
-rw-r--r--sci-libs/cantera/cantera-3.0.0.ebuild14
2 files changed, 15 insertions, 11 deletions
diff --git a/sci-libs/cantera/cantera-2.6.0-r2.ebuild b/sci-libs/cantera/cantera-2.6.0-r2.ebuild
index b7276b05cc38..d024ceeacfc7 100644
--- a/sci-libs/cantera/cantera-2.6.0-r2.ebuild
+++ b/sci-libs/cantera/cantera-2.6.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,20 +27,22 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
- lapack? ( virtual/lapack )
+ dev-cpp/yaml-cpp
cti? (
$(python_gen_cond_dep '
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
')
)
+ !lapack? ( sci-libs/sundials:0= )
+ lapack? (
+ >=sci-libs/sundials-6.5.0:0=[lapack?]
+ virtual/lapack
+ )
python? (
$(python_gen_cond_dep '
dev-python/numpy[${PYTHON_USEDEP}]
')
)
- dev-cpp/yaml-cpp
- !lapack? ( sci-libs/sundials:0= )
- lapack? ( >=sci-libs/sundials-6.5.0:0=[lapack?] )
"
# <cython-3 for bug #913141
diff --git a/sci-libs/cantera/cantera-3.0.0.ebuild b/sci-libs/cantera/cantera-3.0.0.ebuild
index 27478930c415..d53ba2538180 100644
--- a/sci-libs/cantera/cantera-3.0.0.ebuild
+++ b/sci-libs/cantera/cantera-3.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,17 +26,19 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
- lapack? ( virtual/lapack )
+ dev-cpp/yaml-cpp
+ hdf5? ( sci-libs/HighFive )
+ !lapack? ( sci-libs/sundials:0= )
+ lapack? (
+ >=sci-libs/sundials-6.5.0:0=[lapack?]
+ virtual/lapack
+ )
python? (
$(python_gen_cond_dep '
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
')
)
- dev-cpp/yaml-cpp
- hdf5? ( sci-libs/HighFive )
- !lapack? ( sci-libs/sundials:0= )
- lapack? ( >=sci-libs/sundials-6.5.0:0=[lapack?] )
"
DEPEND="