summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-21 03:14:58 +0000
committerSam James <sam@gentoo.org>2022-02-21 03:14:58 +0000
commit381c712ea96ac4f907a6bbe64a1ed7729632442d (patch)
tree60adb1f284e5b5283a4242196f5acfe4f549a373 /sci-libs
parentdev-libs/cereal: add 1.3.1 (diff)
downloadgentoo-381c712ea96ac4f907a6bbe64a1ed7729632442d.tar.gz
gentoo-381c712ea96ac4f907a6bbe64a1ed7729632442d.tar.bz2
gentoo-381c712ea96ac4f907a6bbe64a1ed7729632442d.zip
sci-libs/symengine: mask USE=llvm
Needs some build system work and I can't get to the bottom of it right now. Bug: https://bugs.gentoo.org/745915 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/symengine/symengine-0.9.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sci-libs/symengine/symengine-0.9.0.ebuild b/sci-libs/symengine/symengine-0.9.0.ebuild
index 410eda0d44e7..fa93ed6e4d1f 100644
--- a/sci-libs/symengine/symengine-0.9.0.ebuild
+++ b/sci-libs/symengine/symengine-0.9.0.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit cmake toolchain-funcs
+LLVM_MAX_SLOT=13
+inherit cmake llvm toolchain-funcs
DESCRIPTION="Fast symbolic manipulation library, written in C++"
HOMEPAGE="https://github.com/symengine/symengine"
@@ -13,7 +14,7 @@ LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm64 ~x86"
# BUILD_FOR_DISTRIBUTION enables threads by default so do it here
-IUSE="arb benchmarks boost debug doc ecm flint llvm mpc mpfr openmp test tcmalloc +threads"
+IUSE="arb benchmarks boost debug doc ecm +flint llvm +mpc +mpfr openmp test tcmalloc +threads"
RESTRICT="!test? ( test )"
RDEPEND="dev-libs/gmp:=
@@ -23,6 +24,7 @@ RDEPEND="dev-libs/gmp:=
ecm? ( sci-mathematics/gmp-ecm )
flint? ( sci-mathematics/flint:= )
mpc? ( dev-libs/mpc:= )
+ llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
tcmalloc? ( dev-util/google-perftools )"
DEPEND="${RDEPEND}
dev-libs/cereal"
@@ -36,6 +38,12 @@ pkg_pretend() {
use openmp && [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
+pkg_setup() {
+ use openmp && [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+
+ use llvm && llvm_pkg_setup
+}
+
src_prepare() {
cmake_src_prepare