summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-12-08 14:22:17 +0000
committerSam James <sam@gentoo.org>2025-01-05 21:46:31 +0000
commit2ca921acced99a150f529b9b9eddec5f14d174a9 (patch)
tree9cf07c0a9f55f28d552309604e16607a83b235f5 /sci-libs
parentdev-util/Tensile: add 6.3.0 (diff)
downloadgentoo-2ca921acced99a150f529b9b9eddec5f14d174a9.tar.gz
gentoo-2ca921acced99a150f529b9b9eddec5f14d174a9.tar.bz2
gentoo-2ca921acced99a150f529b9b9eddec5f14d174a9.zip
sci-libs/hipBLAS: add 6.3.0
Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hipBLAS/Manifest1
-rw-r--r--sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild4
-rw-r--r--sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild42
3 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/hipBLAS/Manifest b/sci-libs/hipBLAS/Manifest
index 2e8dfa39138c..4b86cef79d3b 100644
--- a/sci-libs/hipBLAS/Manifest
+++ b/sci-libs/hipBLAS/Manifest
@@ -2,3 +2,4 @@ DIST hipBLAS-5.1.3.tar.gz 526704 BLAKE2B d32d7029ea910c341e00dccab1ee9ab98451836
DIST hipBLAS-5.4.2.tar.gz 930814 BLAKE2B 702df09010b50652feb8f7e5741b27117aa58fc3e3b1b5f89f5043073a47581d1710f0831740453e84f7594b1b305e95d2681709898e5231c3eee2e8207404a3 SHA512 a941350d2d25022cf5142f68559242a048136bdd048dafcd544a0241cf3b510062273163f7a0eecc55f17ec47a1063d84d6102ca766ba7cde9b704eee5c44cd8
DIST hipBLAS-5.7.1.tar.gz 669163 BLAKE2B e065f77eba0bb99d347f71920e733d30b7693f9eaf0c1f2a87a169360ccff23b8294e367eebfd6489440308b9bb1ae662c39617c5bb94275bf9b0ed60d555f85 SHA512 24c074f07865e1a3dfb0aca0b1d494e340a584ecb408813bb5b053f8282437cfd3644d730163f4faf1b93da306626ba68904141f9c3730a29749537fb7fd1a63
DIST hipBLAS-6.1.1.tar.gz 835570 BLAKE2B dc8a54f3b6c780f63e57f208d67b15e965d3a7c98e20766ef22ecfd41e8780a6b9464e31efad8003b52562222ec7ad06801d93a502ff99f8456f415db09e5ace SHA512 390b9a9bf0238a5c72d51d034c0053ec8c6b007547b1ec9561064828c24335e099ddb0402ad76e60018ec96742d5acfbb29b9d218a613e1c6d54e4b8b05ceca7
+DIST hipBLAS-6.3.0.tar.gz 993145 BLAKE2B 6bd6108c90c511fb9e68f628714545569dac9afe9f022f9d59e365f44177ae574a4e3b94c9276b64aad3c72c94d5b3d87babe79edbb9cc2e6d5cbaebb82f3a83 SHA512 c5d40a6dcce467e44b091c610d35dc7abfe9e863b37438642e98568a3f8b084ffd94ee41e466a60f21151df765c0df377d553700e2df2b08375a58f40654f7dc
diff --git a/sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild b/sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild
index 439a778540e9..08e7ed59f34d 100644
--- a/sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild
+++ b/sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild
@@ -23,6 +23,10 @@ RDEPEND="dev-util/hip
DEPEND="${RDEPEND}"
src_configure() {
+ # Note: hipcc is enforced; clang fails when libc++ is enabled
+ # with an error similar to https://github.com/boostorg/config/issues/392
+ rocm_use_hipcc
+
local mycmakeargs=(
# currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
-DBUILD_CLIENTS_TESTS=OFF
diff --git a/sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild b/sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild
new file mode 100644
index 000000000000..c8659df1eeee
--- /dev/null
+++ b/sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+DESCRIPTION="ROCm BLAS marshalling library"
+HOMEPAGE="https://github.com/ROCm/hipBLAS"
+SRC_URI="https://github.com/ROCm/hipBLAS/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/hipBLAS-rocm-${PV}"
+
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-util/hip:${SLOT}
+ sci-libs/hipBLAS-common:${SLOT}
+ sci-libs/rocBLAS:${SLOT}[${ROCM_USEDEP}]
+ sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Note: hipcc is enforced; clang fails when libc++ is enabled
+ # with an error similar to https://github.com/boostorg/config/issues/392
+ rocm_use_hipcc
+
+ local mycmakeargs=(
+ # currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
+ -DBUILD_CLIENTS_TESTS=OFF
+ -DBUILD_CLIENTS_BENCHMARKS=OFF
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ cmake_src_configure
+}