summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-10-22 05:17:25 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-01-05 10:32:42 +0200
commitaeaf7f406a8e46d1e4b8a9d037e2c5776a5d79c8 (patch)
tree042a07d3e0b3ed8e3d29119160d14d2fa49810f7 /sci-libs/scalapack
parentapp-crypt/aescrypt: bump to 3.14 (diff)
downloadgentoo-aeaf7f406a8e46d1e4b8a9d037e2c5776a5d79c8.tar.gz
gentoo-aeaf7f406a8e46d1e4b8a9d037e2c5776a5d79c8.tar.bz2
gentoo-aeaf7f406a8e46d1e4b8a9d037e2c5776a5d79c8.zip
sci-libs/scalapack: fixed GCC10 build issues
Closes: https://bugs.gentoo.org/727340 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/18000 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-libs/scalapack')
-rw-r--r--sci-libs/scalapack/Manifest1
-rw-r--r--sci-libs/scalapack/scalapack-2.1.0.ebuild30
2 files changed, 18 insertions, 13 deletions
diff --git a/sci-libs/scalapack/Manifest b/sci-libs/scalapack/Manifest
index d30e37fd8aab..a0cbd514cbc4 100644
--- a/sci-libs/scalapack/Manifest
+++ b/sci-libs/scalapack/Manifest
@@ -1,2 +1,3 @@
DIST scalapack-2.0.2.tgz 4779534 BLAKE2B c2aabd87bc8f7c0d9af31bd8ad8c933703dcbba399658d15c1e5256da2350c1a0feac2ca4a205f697b1c48083df89cbcd64ba432da036081c0f33d5d2acddc9b SHA512 92c71d3de0900955511c527ab3ca57ff69d6d9edc390e69f93ac3769d32ce83a714326bcb6218c8c74b8874be2fdc8aad5e42c912a12581e8d4ce8829ea39248
+DIST scalapack-2.1.0-gcc10.patch 231026 BLAKE2B dacecca8307cd2bf7a20e6453fb17bc1f5a3f2926b6d8f3b89f7f8d34993368574804f0427f228de4525f2b2d73105de561588ba5a4d2fb609d5ed035f51ddc9 SHA512 a11057599639c167e907f8e4d45204174fd326e2ffb9e2d05533db23d8e2dd8cfc1d37f06d5502baa3d5714092fbf4638cf4d9fea84ca9d4fb150e21cc57861e
DIST scalapack-2.1.0.tgz 5307441 BLAKE2B 4aea055fc3e437bce7108d1555e93c50109bcfe84354903fd711509eedbe686349fda4030e2fa70faf1a9e7e3255e46e48c32b96a2916af6812b8aebceb750c2 SHA512 0e77fb535ebcc28e2d97499ef4bd5161f76ca0ba4a3e308c26ce5071cfc4be4f3814262f3fb38f378ce0b5b31c0913432fea00a1e9e3f7717b853d1182bdf5b4
diff --git a/sci-libs/scalapack/scalapack-2.1.0.ebuild b/sci-libs/scalapack/scalapack-2.1.0.ebuild
index a1979a20ad64..d755a5b1ea9d 100644
--- a/sci-libs/scalapack/scalapack-2.1.0.ebuild
+++ b/sci-libs/scalapack/scalapack-2.1.0.ebuild
@@ -1,13 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils fortran-2 toolchain-funcs
+inherit cmake fortran-2 toolchain-funcs
+
+GCC10_PATCH_HASH="bc6cad585362aa58e05186bb85d4b619080c45a9"
DESCRIPTION="Subset of LAPACK routines redesigned for heterogenous (MPI) computing"
HOMEPAGE="https://www.netlib.org/scalapack/"
-SRC_URI="https://www.netlib.org/scalapack/${P}.tgz"
+SRC_URI="
+ https://www.netlib.org/scalapack/${P}.tgz
+ https://github.com/Reference-ScaLAPACK/scalapack/commit/${GCC10_PATCH_HASH}.patch -> ${P}-gcc10.patch
+ "
LICENSE="BSD"
SLOT="0"
@@ -15,17 +20,16 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
virtual/lapack
virtual/mpi"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
-PATCHES=(
-)
+PATCHES=( "${DISTDIR}/${P}-gcc10.patch" )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use static-libs; then
mkdir "${WORKDIR}/${PN}_static" || die
@@ -43,7 +47,7 @@ src_configure() {
-DBUILD_TESTING=$(usex test)
$@
)
- cmake-utils_src_configure
+ cmake_src_configure
}
scalapack_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
@@ -53,15 +57,15 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake_src_compile
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake_src_install
insinto /usr/include/blacs
doins BLACS/SRC/*.h