summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:26 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:26 +0200
commit2f596c981ecfb40bbe1a93091641b1f41c16435c (patch)
treefb92cf079d35a746b1412ee5dac1d34cb463d19f /sci-libs/nfft/nfft-3.5.2.ebuild
parentsci-libs/lis: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-2f596c981ecfb40bbe1a93091641b1f41c16435c.tar.gz
gentoo-2f596c981ecfb40bbe1a93091641b1f41c16435c.tar.bz2
gentoo-2f596c981ecfb40bbe1a93091641b1f41c16435c.zip
sci-libs/nfft: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/nfft/nfft-3.5.2.ebuild')
-rw-r--r--sci-libs/nfft/nfft-3.5.2.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/sci-libs/nfft/nfft-3.5.2.ebuild b/sci-libs/nfft/nfft-3.5.2.ebuild
index f0ea656c7539..066540701d6c 100644
--- a/sci-libs/nfft/nfft-3.5.2.ebuild
+++ b/sci-libs/nfft/nfft-3.5.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,18 +18,11 @@ RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
DEPEND="${RDEPEND}"
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
- die "need openmp capable compiler"
- fi
- fi
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {