summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-31 21:46:11 -0400
committerSam James <sam@gentoo.org>2024-04-01 06:29:26 +0100
commitd7bd3f9525291e25cbae8c6f107227d6a14a4c4f (patch)
treee13fdfde6434aeeee8072dbf38621766eefd4341 /sci-libs/netcdf-fortran
parentsci-libs/lis: add missing dep for switch to zip distfile (diff)
downloadgentoo-d7bd3f9525291e25cbae8c6f107227d6a14a4c4f.tar.gz
gentoo-d7bd3f9525291e25cbae8c6f107227d6a14a4c4f.tar.bz2
gentoo-d7bd3f9525291e25cbae8c6f107227d6a14a4c4f.zip
sci-libs/netcdf-fortran: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/927588 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/netcdf-fortran')
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.5.4-r1.ebuild7
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild7
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4-r1.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4-r1.ebuild
index 2677655adbea..011dff676f10 100644
--- a/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4-r1.ebuild
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
FORTRAN_STANDARD="77 90"
-inherit fortran-2
+inherit flag-o-matic fortran-2
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -25,6 +25,11 @@ DEPEND="
BDEPEND="doc? ( app-text/doxygen )"
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/927588
+ # https://github.com/Unidata/netcdf-fortran/issues/437
+ filter-lto
+
econf \
--disable-valgrind \
--with-temp-large="${T}" \
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
index d89617045f7d..fc08cfb95414 100644
--- a/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
FORTRAN_STANDARD="77 90"
-inherit autotools fortran-2
+inherit autotools flag-o-matic fortran-2
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -28,6 +28,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/927588
+ # https://github.com/Unidata/netcdf-fortran/issues/437
+ filter-lto
+
econf \
--disable-valgrind \
--with-temp-large="${T}" \
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
index f9c020fa3521..9b44a0997205 100644
--- a/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
FORTRAN_STANDARD="77 90"
-inherit cmake fortran-2
+inherit cmake flag-o-matic fortran-2
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -25,6 +25,11 @@ DEPEND="
BDEPEND="doc? ( app-text/doxygen[dot] )"
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/927588
+ # https://github.com/Unidata/netcdf-fortran/issues/437
+ filter-lto
+
local mycmakeargs=(
-DDISABLE_ZSTANDARD_PLUGIN=$(usex !zstd)
-DBUILD_EXAMPLES=$(usex examples)