summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-14 19:45:45 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-14 19:59:58 +0100
commit81ce5ca29c0e4ccf8827303a75146698302cb78d (patch)
tree20957f6ab261f9a41d8b3e3ae2edee19cdf035f3 /sci-libs/libexcelformat/libexcelformat-101016.ebuild
parentsci-chemistry/xyza2pipe: Bump EAPI to 6 (diff)
downloadgentoo-81ce5ca29c0e4ccf8827303a75146698302cb78d.tar.gz
gentoo-81ce5ca29c0e4ccf8827303a75146698302cb78d.tar.bz2
gentoo-81ce5ca29c0e4ccf8827303a75146698302cb78d.zip
sci-libs/libexcelformat: Bump EAPI to 6
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/libexcelformat/libexcelformat-101016.ebuild')
-rw-r--r--sci-libs/libexcelformat/libexcelformat-101016.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-libs/libexcelformat/libexcelformat-101016.ebuild b/sci-libs/libexcelformat/libexcelformat-101016.ebuild
index 5613f42ae56a..6b346b4f29f2 100644
--- a/sci-libs/libexcelformat/libexcelformat-101016.ebuild
+++ b/sci-libs/libexcelformat/libexcelformat-101016.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="reading, writing, and editing of XLS (BIFF8 format) files using C++"
HOMEPAGE="http://www.codeproject.com/KB/office/ExcelFormat.aspx"
@@ -17,12 +17,12 @@ IUSE=""
S="${WORKDIR}"/libExcelFormat
src_prepare() {
+ default
tc-export CXX
}
src_install() {
- insinto /usr/include
- doins *.h* || die
+ doheader *.h*
- dolib.so libExcelFormat.so* || die
+ dolib.so libExcelFormat.so*
}