summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-05-02 20:14:21 +0300
committerSam James <sam@gentoo.org>2023-05-02 18:44:57 +0100
commit020a22ee51f59b72936943e69953b0971acf127f (patch)
tree07c6bf440ba046740977a71f89fb85ab160e006b /sci-libs/gmsh
parentdev-util/gdbus-codegen: Stabilize 2.76.2 sparc, #905568 (diff)
downloadgentoo-020a22ee51f59b72936943e69953b0971acf127f.tar.gz
gentoo-020a22ee51f59b72936943e69953b0971acf127f.tar.bz2
gentoo-020a22ee51f59b72936943e69953b0971acf127f.zip
sci-libs/gmsh: 4.11.1 fix GCC-13 compatibility
Closes: https://bugs.gentoo.org/905445 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/30839 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/gmsh')
-rw-r--r--sci-libs/gmsh/files/gmsh-4.11.1_gcc13_fix_cstdint_include.patch29
-rw-r--r--sci-libs/gmsh/gmsh-4.11.1.ebuild5
2 files changed, 33 insertions, 1 deletions
diff --git a/sci-libs/gmsh/files/gmsh-4.11.1_gcc13_fix_cstdint_include.patch b/sci-libs/gmsh/files/gmsh-4.11.1_gcc13_fix_cstdint_include.patch
new file mode 100644
index 000000000000..2b1b491ef81f
--- /dev/null
+++ b/sci-libs/gmsh/files/gmsh-4.11.1_gcc13_fix_cstdint_include.patch
@@ -0,0 +1,29 @@
+# Based on upstream patches:
+# https://gitlab.onelab.info/gmsh/gmsh/-/commit/fb81a9c90
+# https://gitlab.onelab.info/gmsh/gmsh/-/commit/aceb09c80
+#
+# Upstream issue: https://gitlab.onelab.info/gmsh/gmsh/-/issues/2416
+# Gentoo issue: https://bugs.gentoo.org/905445
+
+diff -Naur a/contrib/QuadMeshingTools/qmtMeshGeometryOptimization.h b/contrib/QuadMeshingTools/qmtMeshGeometryOptimization.h
+--- a/contrib/QuadMeshingTools/qmtMeshGeometryOptimization.h
++++ b/contrib/QuadMeshingTools/qmtMeshGeometryOptimization.h
+@@ -8,6 +8,7 @@
+ #pragma once
+
+ #include <float.h>
++#include <cstdint>
+ #include "qmtMeshUtils.h"
+
+ class SurfaceProjector;
+diff -Naur a/src/mesh/meshGFacePack.cpp b/src/mesh/meshGFacePack.cpp
+--- a/src/mesh/meshGFacePack.cpp
++++ b/src/mesh/meshGFacePack.cpp
+@@ -8,6 +8,7 @@
+ #include <queue>
+ #include <map>
+ #include <vector>
++#include <cstdint>
+ #include "gmsh.h"
+ #include "SPoint2.h"
+ #include "SVector3.h"
diff --git a/sci-libs/gmsh/gmsh-4.11.1.ebuild b/sci-libs/gmsh/gmsh-4.11.1.ebuild
index 5bbf22a1c4b1..faf9c16b04ea 100644
--- a/sci-libs/gmsh/gmsh-4.11.1.ebuild
+++ b/sci-libs/gmsh/gmsh-4.11.1.ebuild
@@ -68,7 +68,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${P}-source
-PATCHES=( "${FILESDIR}"/${PN}-4.9.5-opencascade.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.9.5-opencascade.patch
+ "${FILESDIR}"/${P}_gcc13_fix_cstdint_include.patch
+)
pkg_setup() {
fortran-2_pkg_setup