summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMo Zhou <cdluminate@gmail.com>2019-06-30 06:48:01 +0000
committerBenda Xu <heroxbd@gentoo.org>2019-07-03 21:01:28 +0800
commitd0944e08f322eed61cfcd1293792732a8eb72bfd (patch)
tree8ad07ccd1cf07402a109a8745f96c67f5ffde99d /sci-libs/blis/files
parentsys-kernel/gentoo-sources: Linux patch 5.1.16 (diff)
downloadgentoo-d0944e08f322eed61cfcd1293792732a8eb72bfd.tar.gz
gentoo-d0944e08f322eed61cfcd1293792732a8eb72bfd.tar.bz2
gentoo-d0944e08f322eed61cfcd1293792732a8eb72bfd.zip
sci-libs/blis: bump to 0.6.0, getting rid of a patch.
Closes: https://github.com/gentoo/gentoo/pull/12358 Signed-off-by: Mo Zhou <cdluminate@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/blis/files')
-rw-r--r--sci-libs/blis/files/blis-0.6.0-blas-provider.patch13
-rw-r--r--sci-libs/blis/files/blis-0.6.0-rpath.patch13
2 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/blis/files/blis-0.6.0-blas-provider.patch b/sci-libs/blis/files/blis-0.6.0-blas-provider.patch
new file mode 100644
index 000000000000..5999f847929c
--- /dev/null
+++ b/sci-libs/blis/files/blis-0.6.0-blas-provider.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 2d31fee..7008682 100644
+--- a/Makefile
++++ b/Makefile
+@@ -659,6 +659,8 @@ else
+ @$(LINKER) $(SOFLAGS) -o $(LIBBLIS_SO_OUTPUT_NAME) $? $(LDFLAGS)
+ endif
+ endif
++ $(LINKER) $(SOFLAGS) -o $(BASE_LIB_PATH)/$(DEB_LIBBLAS) $? $(LDFLAGS) -Wl,--soname,$(DEB_LIBBLAS) -Wl,--version-script=$(LDS_BLAS)
++ $(LINKER) $(SOFLAGS) -o $(BASE_LIB_PATH)/$(DEB_LIBCBLAS) $? $(LDFLAGS) -Wl,--soname,$(DEB_LIBCBLAS) -Wl,--version-script=$(LDS_CBLAS)
+
+ # Local symlink for shared library.
+ # NOTE: We use a '.loc' suffix to avoid filename collisions in case this
diff --git a/sci-libs/blis/files/blis-0.6.0-rpath.patch b/sci-libs/blis/files/blis-0.6.0-rpath.patch
new file mode 100644
index 000000000000..a8b5a46870d1
--- /dev/null
+++ b/sci-libs/blis/files/blis-0.6.0-rpath.patch
@@ -0,0 +1,13 @@
+diff --git a/common.mk b/common.mk
+index ef0acfb..e1ce31d 100644
+--- a/common.mk
++++ b/common.mk
+@@ -527,7 +527,7 @@ LIBBLIS_L := $(LIBBLIS_SO)
+ LIBBLIS_LINK := $(LIBBLIS_SO_PATH)
+ ifeq ($(IS_WIN),no)
+ # For Linux and OS X: set rpath property of shared object.
+-LDFLAGS += -Wl,-rpath,$(BASE_LIB_PATH)
++#LDFLAGS += -Wl,-rpath,$(BASE_LIB_PATH)
+ endif
+ endif
+ endif