summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:09:18 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commit0ce3156f1fc7bdf0da647da22241199aa4532b2e (patch)
treed07f2b6a660dec44c4e49b8f584650144e9c3bde /sci-geosciences
parentsci-geosciences/opencpn: drop 3.0.2 (diff)
downloadgentoo-0ce3156f1fc7bdf0da647da22241199aa4532b2e.tar.gz
gentoo-0ce3156f1fc7bdf0da647da22241199aa4532b2e.tar.bz2
gentoo-0ce3156f1fc7bdf0da647da22241199aa4532b2e.zip
sci-geosciences/opencpn-plugin-br24radar: bump version, add live version
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.31.ebuild38
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild38
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-br24radar/Manifest b/sci-geosciences/opencpn-plugin-br24radar/Manifest
index 146bcb85038b..576c581462a2 100644
--- a/sci-geosciences/opencpn-plugin-br24radar/Manifest
+++ b/sci-geosciences/opencpn-plugin-br24radar/Manifest
@@ -1 +1,2 @@
DIST opencpn-plugin-br24radar-1.1.tar.gz 172257 SHA256 7588b3c00175444dbd4c1a54e88e993767af25b784c3a1a20a6ab0ded176238d SHA512 94202b69fc276614c828c0266a3d7ade375f4bd4b26d4acbf92dc9b35c60ac45d7050b1af08667207e856fe9778796dec1786a11e16eba840ed80b140b78e78a WHIRLPOOL c79153da5cad0b8f503e1a3a5a9125ea8cf0ac5b353436ade61922db8f9e5f8937a3c4256d1fe2c972cb114016c5f9bf078b10c10d1d3e9445cf26c84ec1a789
+DIST opencpn-plugin-br24radar-1.31.tar.gz 253695 SHA256 82104da4f9d7e4089030e3845fde2aea5fe962069080df620a044d8d0cb24046 SHA512 30a5aa33e9f40625561477607de93ea77c9096b46c292ea4dcfc9cbec589b5c3e2650dc82ea646d7d353f587f3104493c55aa454cbf91884bf62a6b15e39e2fa WHIRLPOOL 1585cf3707295a7291b2053e1d5e3b10ed587cd36ab39573dabb1c56e3f591dea3a9d2fc3578a6383f4c242bf1694c08a09579ab7edff2bf330355a17caa9bbb
diff --git a/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.31.ebuild b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.31.ebuild
new file mode 100644
index 000000000000..1e07605ae30f
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.31.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="BR24radar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/canboat/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/canboat/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Navico (Simrad, Lowrance) Broadband BR24/3G/4G Radar Plugin for OpenCPN"
+HOMEPAGE="http://opencpn-navico-radar-plugin.github.io/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild
new file mode 100644
index 000000000000..1e07605ae30f
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="BR24radar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/canboat/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/canboat/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Navico (Simrad, Lowrance) Broadband BR24/3G/4G Radar Plugin for OpenCPN"
+HOMEPAGE="http://opencpn-navico-radar-plugin.github.io/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}