summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-17 22:17:06 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-17 22:17:31 +0200
commitbda1499b5ca6ddcc94dde12d107d859912a21c09 (patch)
treeb81b9b6283d55ef5ee5ef490e73cd1e0996699b6 /sci-geosciences/xtide/xtide-2.13.2.ebuild
parentsci-geosciences/seawater: version bump to 3.3.3 (diff)
downloadgentoo-bda1499b5ca6ddcc94dde12d107d859912a21c09.tar.gz
gentoo-bda1499b5ca6ddcc94dde12d107d859912a21c09.tar.bz2
gentoo-bda1499b5ca6ddcc94dde12d107d859912a21c09.zip
sci-geosciences/xtide: version bump to 2.13.2
Diffstat (limited to 'sci-geosciences/xtide/xtide-2.13.2.ebuild')
-rw-r--r--sci-geosciences/xtide/xtide-2.13.2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-geosciences/xtide/xtide-2.13.2.ebuild b/sci-geosciences/xtide/xtide-2.13.2.ebuild
new file mode 100644
index 000000000000..56b0fc127503
--- /dev/null
+++ b/sci-geosciences/xtide/xtide-2.13.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="XTide provides tide and current predictions in a wide variety of formats"
+HOMEPAGE="http://www.flaterco.com/xtide/"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gps"
+
+DEPEND="
+ media-libs/libpng:0
+ >=sci-geosciences/libtcd-2.2.5_p2
+ x11-libs/libX11
+ x11-libs/libXaw3d
+ x11-libs/libXpm
+ x11-libs/libXt
+ gps? ( sci-geosciences/gpsd )"
+RDEPEND="${DEPEND}
+ media-fonts/font-schumacher-misc"
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.13.1-{Werror,gps-switch}.patch \
+ "${FILESDIR}"/${P}-clang.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gps)
+}
+
+src_install() {
+ dobin xtide tide xttpd
+ doman *.[18]
+
+ echo 'HFILE_PATH=/usr/share/harmonics' > 50xtide_harm
+ doenvd 50xtide_harm
+
+ newicon -s 48 iconsrc/icon_48x48_orig.png ${PN}.png
+
+ make_desktop_entry ${PN} 'Tide prediction' ${PN} 'Science'
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}