summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Schlupp <nils.schlupp@gmail.com>2022-05-06 17:27:17 -0700
committerMarc Schiffbauer <mschiff@gentoo.org>2022-05-17 23:16:29 -1000
commit4b231eb29a9468c51f033ef90b0e211c8e77ee12 (patch)
treeac6214420c12c2b6ed91b03e91bd695c78b14625 /sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
parentsci-geosciences/opencpn: update EAPI 7 -> 8 (diff)
downloadgentoo-4b231eb29a9468c51f033ef90b0e211c8e77ee12.tar.gz
gentoo-4b231eb29a9468c51f033ef90b0e211c8e77ee12.tar.bz2
gentoo-4b231eb29a9468c51f033ef90b0e211c8e77ee12.zip
sci-geosciences/opencpn-plugin-weather_routing:
Switching to more recent maintainer branch and bumping to version 1.13.1 Bug: https://bugs.gentoo.org/830067,https://bugs.gentoo.org/831680 Signed-off-by: Nils Schlupp <nils.schlupp@gmail.com> Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
new file mode 100644
index 000000000000..586c24e8abcb
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
+MY_PN="weather_routing_pi"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rgleason/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/rgleason/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Weather Routing Plugin for OpenCPN"
+HOMEPAGE="https://github.com/rgleason/weather_routing_pi/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
+}