summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-06-08 13:22:43 +1000
committerSam Jorna <wraeth@gentoo.org>2016-06-08 13:43:10 +1000
commit3755f809c5278e73f69dc4818b25d16695060446 (patch)
tree4a79190919cc57cfc47c5ff1ae9429621a6c6030 /sci-geosciences/gdal-grass
parentmail-client/thunderbird: mis-release version bump (diff)
downloadgentoo-3755f809c5278e73f69dc4818b25d16695060446.tar.gz
gentoo-3755f809c5278e73f69dc4818b25d16695060446.tar.bz2
gentoo-3755f809c5278e73f69dc4818b25d16695060446.zip
sci-geosciences/gdal-grass: bump to 2.1.0
Version bump to 2.1.0, also replaces patch for one line with sed. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sci-geosciences/gdal-grass')
-rw-r--r--sci-geosciences/gdal-grass/Manifest1
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-geosciences/gdal-grass/Manifest b/sci-geosciences/gdal-grass/Manifest
index a6b2968f2c3f..cf63bc33a9a4 100644
--- a/sci-geosciences/gdal-grass/Manifest
+++ b/sci-geosciences/gdal-grass/Manifest
@@ -1 +1,2 @@
DIST gdal-grass-2.0.0.tar.gz 56286 SHA256 e05b4bedb67d624b86b84fc23a680fc408c6c3444dc94555f6f6febc3c506e69 SHA512 cefa60773c2acd5c1627b896e3298d02f51979c12f70ce67b88c0b886a13de2f62821a3d3e50984f5c676ef37819c685795949b06db57004a0edf8039e898d7e WHIRLPOOL c6c0bf3a06388188a173c14f6f8f4cbe295f849c5950c68f413a357fb4efaf2ddb5a78ea4ced7bd4b6786c979299b7dc5754196ee68ee87a31962f578599a90a
+DIST gdal-grass-2.1.0.tar.gz 54299 SHA256 1faa5d244ebcb5295cab7814c661ba1dee72b27c0e3848677e34b0c97c8111d0 SHA512 fb06b71839849de413f68beb8f2cd1c2273cc48b5205fe1b255ffc4976f8f913b4b226eba186a24f5b40fe5fbb1ceeab760d06915222e4a4b269a6fbc7bc9417 WHIRLPOOL 661b45ed7292a5d43bcf5b483c0d93edc42c7cd55281ef53331fc2690a36d527736c3fcf15a63b4e5f71e2987f9612ad70f2665650b67eff8e4316f39dfcaf7c
diff --git a/sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild b/sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild
new file mode 100644
index 000000000000..50b440e5476e
--- /dev/null
+++ b/sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="GDAL plugin to access GRASS data"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="postgres"
+RDEPEND="
+ >=sci-libs/gdal-2.0.0
+ sci-geosciences/grass:0=
+"
+DEPEND="${RDEPEND}
+ dev-libs/expat
+ dev-libs/json-c
+ virtual/jpeg
+ media-libs/tiff
+ sci-libs/libgeotiff
+ sci-libs/proj
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql )"
+
+# these drivers are copied at install from the already installed GRASS
+QA_PREBUILT="/usr/share/gdal/grass/driver/db/*"
+
+src_prepare() {
+ sed -e 's:mkdir ${GRASSTABLES_DIR}$:mkdir -p ${GRASSTABLES_DIR}:' \
+ -i Makefile.in || die
+ default
+}
+
+src_configure() {
+ econf \
+ --with-grass="/usr/$(get_libdir)/grass70" \
+ --with-gdal="/usr/bin/gdal-config" \
+ $(use_with postgres postgres-includes "/usr/include/postgresql")
+}
+
+src_install() {
+ #pass the right variables to 'make install' to prevent a sandbox access violation
+ emake DESTDIR="${D}" \
+ GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
+ AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
+ install
+}