summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/cdat-lite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/cdat-lite')
-rw-r--r--sci-geosciences/cdat-lite/Manifest1
-rw-r--r--sci-geosciences/cdat-lite/cdat-lite-6.0_rc2.ebuild44
-rw-r--r--sci-geosciences/cdat-lite/files/cdat-lite-6.0_rc2-QA.patch132
-rw-r--r--sci-geosciences/cdat-lite/metadata.xml9
4 files changed, 186 insertions, 0 deletions
diff --git a/sci-geosciences/cdat-lite/Manifest b/sci-geosciences/cdat-lite/Manifest
new file mode 100644
index 000000000000..9de625d40766
--- /dev/null
+++ b/sci-geosciences/cdat-lite/Manifest
@@ -0,0 +1 @@
+DIST cdat_lite-6.0rc2.tar.gz 3563402 SHA256 6cbfdf9b47fdbc189ca7d2819dafb6cf958116e0f6077b325c375a0ddfab2a95 SHA512 bf6bc00305d29adbb2608865a56e2fe36dde56f4d7a0e63266549ce5e74120be602ac16c3e1c02bc9216e7c613ad92697f6a61a4b02158e1bf46e178d841a90f WHIRLPOOL 9cbb784402713231c89b37eb69969ed1431848d38973eb1d3682c260509ae892c35c97a96f386713e9ff30e0d51fbe9197073aa92533b92f799b2331db61d41f
diff --git a/sci-geosciences/cdat-lite/cdat-lite-6.0_rc2.ebuild b/sci-geosciences/cdat-lite/cdat-lite-6.0_rc2.ebuild
new file mode 100644
index 000000000000..ac330e0dea6a
--- /dev/null
+++ b/sci-geosciences/cdat-lite/cdat-lite-6.0_rc2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk,xml"
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit eutils distutils-r1 toolchain-funcs
+
+MY_P=${P/-/_}
+MY_P=${MY_P/_rc/rc}
+
+DESCRIPTION="Large suite of open source tools for the management and analysis of climate data"
+HOMEPAGE="http://proj.badc.rl.ac.uk/cedaservices/wiki/CdatLite"
+SRC_URI="http://ndg.nerc.ac.uk/dist/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=sci-libs/netcdf-4.0.1
+ >=sci-libs/hdf5-1.6.4
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ virtual/pmw[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}
+ !sci-biology/ncbi-tools"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ tc-export CC FC RANLIB AR
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-QA.patch
+ find "${S}" -type l -delete || die
+ distutils-r1_src_prepare
+}
diff --git a/sci-geosciences/cdat-lite/files/cdat-lite-6.0_rc2-QA.patch b/sci-geosciences/cdat-lite/files/cdat-lite-6.0_rc2-QA.patch
new file mode 100644
index 000000000000..a00206ea739d
--- /dev/null
+++ b/sci-geosciences/cdat-lite/files/cdat-lite-6.0_rc2-QA.patch
@@ -0,0 +1,132 @@
+--- cdat_lite-6.0rc2/libcdms/Makefile.in
++++ cdat_lite-6.0rc2/libcdms/Makefile.in
+@@ -44,15 +44,15 @@
+ PARMDIR=$(prefix)/lib/lats
+
+ CC = @CC@
+-CFLAGS = -I../../include @CFLAGS@ $(DEBUG) -Dgrads @GRIB2INC@ @GRIB2OPTS@
++CFLAGS = -fPIC -I../../include @CFLAGS@ -Dgrads @GRIB2INC@ @GRIB2OPTS@
+ CPPFLAGS = @CPPFLAGS@
+ DEBUG = -O
+ DEFS = @DEFS@
+ FC = @FC@
+-FFLAGS = -I../../include @FFLAGS@ $(DEBUG)
++FFLAGS = -I../../include @FFLAGS@
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+-LDFLAGS = -L../../../lib -lcdms @NCOPTS@ @HDFOPTS@ @DRSOPTS@ @LIBS@ @GRIB2LIB@
++LDFLAGS += -L../../../lib -lcdms @NCOPTS@ @HDFOPTS@ @DRSOPTS@ @LIBS@ @GRIB2LIB@
+ OS = @OS@
+ RANLIB = @RANLIB@
+
+--- cdat_lite-6.0rc2/libcdms/src/db_util/Makefile.in
++++ cdat_lite-6.0rc2/libcdms/src/db_util/Makefile.in
+@@ -38,17 +38,18 @@
+ PARMDIR=$(prefix)/lib/lats
+
+ CC = @CC@
+-CFLAGS = -I../../include @CFLAGS@ $(DEBUG) -Dgrads
++CFLAGS = -fPIC -I../../include @CFLAGS@ -Dgrads
+ CPPFLAGS = @CPPFLAGS@
+ DEBUG = -O
+ DEFS = @DEFS@
+ FC = @FC@
+-FFLAGS = -I../../include @FFLAGS@ $(DEBUG)
++FFLAGS = -I../../include @FFLAGS@
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+-LDFLAGS = -L../../../lib -lcdms @NCOPTS@ @DRSOPTS@ @LIBS@
++LDFLAGS += -L../../../lib -lcdms @NCOPTS@ @DRSOPTS@ @LIBS@
+ OS = @OS@
+ RANLIB = @RANLIB@
++AR ?= ar
+
+ # Shell to run make subcommands
+ SHELL = /bin/sh
+@@ -60,7 +61,7 @@
+ cdUtil.o
+
+ all: $(OBJS) FORCE
+- ar rv $(LIBRARY) $(OBJS)
++ $(AR) rv $(LIBRARY) $(OBJS)
+ $(RANLIB) $(LIBRARY)
+
+ cdTimeConv.o: cdTimeConv.c ../../include/cdmsint.h ../../include/cdms.h ../../include/cdunif.h
+--- cdat_lite-6.0rc2/libcdms/src/cdunif/Makefile.in
++++ cdat_lite-6.0rc2/libcdms/src/cdunif/Makefile.in
+@@ -47,29 +47,29 @@
+ PARMDIR=$(prefix)/lib/lats
+
+ # Set the compiler flag for the 64-bit Opteron platform
++CC = @CC@
+ ARCH=$(shell uname -m)
+ ifeq ($(ARCH),x86_64)
+- CC = gcc -fPIC -D__x86_64__
+-else
+- CC = @CC@
++ CC += -fPIC -D__x86_64__
+ endif
+
+ ifneq (@GRIB2INC@,)
+- CFLAGS = -I../../include -I"@NCINC@" -I@HDFINC@ -I@DRSINC@ @CFLAGS@ $(DEBUG) -Dgrads -I@GRIB2INC@ @GRIB2OPTS@
++ CFLAGS = -I../../include -I"@NCINC@" -I@HDFINC@ -I@DRSINC@ @CFLAGS@ -Dgrads -I@GRIB2INC@ @GRIB2OPTS@
+ else
+- CFLAGS = -I../../include -I"@NCINC@" -I@HDFINC@ -I@DRSINC@ @CFLAGS@ $(DEBUG) -Dgrads
++ CFLAGS = -I../../include -I"@NCINC@" -I@HDFINC@ -I@DRSINC@ @CFLAGS@ -Dgrads
+ endif
+
+-CPPFLAGS = @CPPFLAGS@ -DSTNDALN=1 -DBYTEORDER=@GRADS_BYTEORDER@ -DGRADS_CRAY=@GRADS_CRAY@ @QLOPTS@ @PPOPTS@ @GRIB2OPTS@
++CPPFLAGS += @CPPFLAGS@ -DSTNDALN=1 -DBYTEORDER=@GRADS_BYTEORDER@ -DGRADS_CRAY=@GRADS_CRAY@ @QLOPTS@ @PPOPTS@ @GRIB2OPTS@
+ DEBUG = -O
+ DEFS = @DEFS@
+ FC = @FC@
+-FFLAGS = -I../../include @FFLAGS@ $(DEBUG)
++FFLAGS = -I../../include @FFLAGS@
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+-LDFLAGS = -L../../../lib -lcdms @NCOPTS@ @HDFOPTS@ @DRSOPTS@ @LIBS@ @GRIB2LIB@
++LDFLAGS += -L../../../lib -lcdms @NCOPTS@ @HDFOPTS@ @DRSOPTS@ @LIBS@ @GRIB2LIB@
+ OS = @OS@
+ RANLIB = @RANLIB@
++AR ?= ar
+
+ # Shell to run make subcommands
+ SHELL = /bin/sh
+@@ -80,7 +80,7 @@
+ OBJS = cdunif.o cdunifint.o cdunifgen.o cdunifdrs.o cdunifgrads.o cdunifnc.o cdunifhdf.o cdunifslab.o cdunifstub.o cdunifra.o cdrra.o cdsort.o gamach.o gaio.o gaprnt.o gautil.o gaddes.o galloc.o gabufr.o gabufrtbl.o cdunifql.o @GRADS_IEEE2CRAY_OBJECT@
+
+ all: $(OBJS) FORCE
+- ar rv $(LIBRARY) $(OBJS)
++ $(AR) rv $(LIBRARY) $(OBJS)
+ cd cdunifpp; $(MAKE) DEBUG=$(DEBUG)
+ $(RANLIB) $(LIBRARY)
+
+--- cdat_lite-6.0rc2/libcdms/src/cdunif/cdunifpp/Makefile.in
++++ cdat_lite-6.0rc2/libcdms/src/cdunif/cdunifpp/Makefile.in
+@@ -37,12 +37,13 @@
+ # set to blank if you don't want to rename symbols in unpacking routines
+
+ CC = @CC@
+-CFLAGS = -I../../../include/cdunifpp -I@NCINC@ @CFLAGS@ -I../../../include $(DEBUG)
++CFLAGS = -fPIC -I../../../include/cdunifpp -I@NCINC@ @CFLAGS@ -I../../../include
+ CPPFLAGS = @CPPFLAGS@ @PPOPTS@ -Uhdf
+ LIBRARY = ../../../lib/libcdms.a
++AR ?= ar
+
+ all: $(OBJS)
+- ar rv $(LIBRARY) $(OBJS)
++ $(AR) rv $(LIBRARY) $(OBJS)
+ # (ranlib called by higher-level makefile)
+
+ %.o: %.c $(HEADERS)
+--- cdat_lite-6.0rc2/setup_util.py
++++ cdat_lite-6.0rc2/setup_util.py
+@@ -296,8 +296,6 @@
+ nc4_defs = ''
+
+ self._system('cd libcdms ; '
+- 'CFLAGS="-fPIC" '
+- 'CC=%(cc)s '
+ 'sh ./configure --disable-drs --disable-hdf '
+ '--disable-ql --with-ncinc=%(ncinc)s --with-ncincf=%(ncinc)s --with-nclib=%(nclib)s %(nc4)s'
+ % dict(ncinc=netcdf_config.netcdf_incdir, nclib=netcdf_config.netcdf_libdir,
diff --git a/sci-geosciences/cdat-lite/metadata.xml b/sci-geosciences/cdat-lite/metadata.xml
new file mode 100644
index 000000000000..0744b87d36ba
--- /dev/null
+++ b/sci-geosciences/cdat-lite/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+</maintainer>
+</pkgmetadata>
+