summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-18 23:05:12 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-18 23:05:43 +0300
commitfc4ee19d281cd3ecd973f03ecccd3e25603f1c89 (patch)
treeb59d5d2295207343393bd59054a645d619c9a937 /sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
parentdev-util/gprof2dot: Fix DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-fc4ee19d281cd3ecd973f03ecccd3e25603f1c89.tar.gz
gentoo-fc4ee19d281cd3ecd973f03ecccd3e25603f1c89.tar.bz2
gentoo-fc4ee19d281cd3ecd973f03ecccd3e25603f1c89.zip
sci-electronics/fasthenry: Version bump
Closes: https://bugs.gentoo.org/723632 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild')
-rw-r--r--sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
new file mode 100644
index 000000000000..5e4970bb32f9
--- /dev/null
+++ b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Three dimensional inductance computation program, Whiteley Research version"
+HOMEPAGE="http://www.wrcad.com/freestuff.html"
+SRC_URI="http://www.wrcad.com/ftp/pub/fasthenry-$(ver_cut 1-2)wr-$(ver_cut 4)$(ver_cut 5)$(ver_cut 3).tar.gz"
+
+LICENSE="all-rights-reserved"
+RESTRICT="mirror bindist"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/fasthenry-3.0wr
+
+PATCHES=(
+ "${FILESDIR}/${P}-cflags.patch"
+)
+
+src_compile() {
+ tc-export CC
+ emake all
+}
+
+src_install() {
+ dobin bin/fasthenry
+ dobin bin/zbuf
+ dodoc -r doc/*
+ dodoc -r examples
+}