summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/mopac7
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/Manifest3
-rw-r--r--sci-chemistry/mopac7/files/Makefile23
-rw-r--r--sci-chemistry/mopac7/metadata.xml8
-rw-r--r--sci-chemistry/mopac7/mopac7-1.15-r1.ebuild66
-rw-r--r--sci-chemistry/mopac7/mopac7-1.15.ebuild75
5 files changed, 175 insertions, 0 deletions
diff --git a/sci-chemistry/mopac7/Manifest b/sci-chemistry/mopac7/Manifest
new file mode 100644
index 000000000000..d352d6ff544a
--- /dev/null
+++ b/sci-chemistry/mopac7/Manifest
@@ -0,0 +1,3 @@
+DIST dcart.f 11044 SHA256 cdc4082b6b3811eca25eaf674e9345fcd37f58dfbdca3c5d72e9c4e88c47dec9 SHA512 788a184fd8419ff742e49c1a652d5ea093f9114dbe4f272665b8fb9eeac2afb7f7042628c288f2b81d0f54d8a7ef2f400490cd3aff39dda59a6d70a0deab5b80 WHIRLPOOL 399d7cf92d6fd27bb785c3f81eb24ec9615144b3e8605779d1f1f645ea16644a858428d8dfce44c102a495f984e1ae158fe7743ad0bef2b957ea10adc94ccb73
+DIST gmxmop.f 38956 SHA256 918bfac91b1dab65f7a8f759c3fd49e40be19bbddb6869d95f8e345830b93b67 SHA512 38bb2e5749c4d3c8c24f15682f72e40cb4edb6517c7916cecee1d21675b1870c0fe331ba2ec40312408dec473141e7742d1e155d4b64f1c2a25bfa4e11885194 WHIRLPOOL a0adaf3df1167d9675197f71ae2cd5a9a583eef4523b9a074d39291032dbfe0428349ebf78fabd88ed7e1deb5af093be319c9f19cab019deb52f0fb6e3924998
+DIST mopac7-1.15.tar.gz 764547 SHA256 6d7ac5d78522db70f7794fd816cea32829cfa9e93774202fe80ba5a54375fbaa SHA512 e0ccd643caa6dbd7e156867530d79e50e10243f5e3b5f8bc57781e68e1daf26f2a0e6987fff00afe07eb0fcb98cbd9f01e4cfa5d20acc0d8ab3cca632968636e WHIRLPOOL fe4d71e3900b8fe09697275c25bc239e8f94e97d2a570bf6df03c5bd59a3b2ab80bc7f255f739f09c0fc54037e9739b38cec205590ad3cb31ad58fe2067562d2
diff --git a/sci-chemistry/mopac7/files/Makefile b/sci-chemistry/mopac7/files/Makefile
new file mode 100644
index 000000000000..50370b3c2784
--- /dev/null
+++ b/sci-chemistry/mopac7/files/Makefile
@@ -0,0 +1,23 @@
+VERSION = GENTOOVERSION
+MAJOR = 1
+
+LIBS = -lgfortran -lf2c
+
+objects := $(patsubst %.f,%.o,$(wildcard *.f))
+
+all: libgmxmopac7
+
+clean:
+ rm -f moldat.*f deriv.* mopac7*.* compfg.* dcart.*
+
+%.o: %.f
+ $(FC) $(FFLAGS) -fPIC -c $<
+
+libgmxmopac7: $(objects)
+ $(FC) -shared $(LDFLAGS) -Wl,-soname,libgmxmopac7.so.$(MAJOR) -o $@.so.$(VERSION) $^ $(LIBS)
+ ln -sf $@.so.$(VERSION) libgmxmopac7.so
+
+static: $(objects)
+ ar rcv libgmxmopac7.a *.o
+ ranlib libgmxmopac7.a
+
diff --git a/sci-chemistry/mopac7/metadata.xml b/sci-chemistry/mopac7/metadata.xml
new file mode 100644
index 000000000000..839734dd5d8b
--- /dev/null
+++ b/sci-chemistry/mopac7/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <use>
+ <flag name="gmxmopac7">Add support library for gromacs</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-chemistry/mopac7/mopac7-1.15-r1.ebuild b/sci-chemistry/mopac7/mopac7-1.15-r1.ebuild
new file mode 100644
index 000000000000..ce0c326678ec
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.15-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools fortran-2 flag-o-matic toolchain-funcs
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="
+ http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz
+ http://wwwuser.gwdg.de/~ggroenh/qmmm/mopac/dcart.f
+ http://wwwuser.gwdg.de/~ggroenh/qmmm/mopac/gmxmop.f"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE="gmxmopac7 static-libs"
+
+DEPEND="dev-libs/libf2c"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Install the executable
+ sed -i \
+ -e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
+ fortran/Makefile.am \
+ || die "sed failed: install mopac7"
+ # Install the script to run the executable
+ sed -i \
+ -e "s:EXTRA_DIST = autogen.sh run_mopac7:bin_SCRIPTS = run_mopac7:g" \
+ Makefile.am \
+ || die "sed failed: install run_mopac7"
+
+ eautoreconf
+ append-fflags -std=legacy -fno-automatic
+}
+
+src_compile() {
+ emake
+ if use gmxmopac7; then
+ einfo "Making mopac7 lib for gromacs"
+ mkdir "${S}"/fortran/libgmxmopac7 && cd "${S}"/fortran/libgmxmopac7
+ cp -f ../SIZES ../*.f "${FILESDIR}"/Makefile . || die
+ emake clean
+ cp -f "${DISTDIR}"/gmxmop.f "${DISTDIR}"/dcart.f . || die
+ sed "s:GENTOOVERSION:${PV}:g" -i Makefile
+ emake FC=$(tc-getFC)
+ use static-libs && emake static
+ fi
+}
+
+src_install() {
+ # A correct fix would have a run_mopac7.in with @bindir@ that gets
+ # replaced by configure, and run_mopac7 added to AC_OUTPUT in configure.ac
+ sed -i "s:./fortran/mopac7:mopac7:g" run_mopac7 || die
+
+ default
+
+ if use gmxmopac7; then
+ cd "${S}"/fortran/libgmxmopac7
+ dolib.so libgmxmopac7.so*
+ use static-libs && dolib.a libgmxmopac7.a
+ fi
+}
diff --git a/sci-chemistry/mopac7/mopac7-1.15.ebuild b/sci-chemistry/mopac7/mopac7-1.15.ebuild
new file mode 100644
index 000000000000..167561f7ed96
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.15.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools fortran-2 toolchain-funcs
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="
+ http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz
+ http://wwwuser.gwdg.de/~ggroenh/qmmm/mopac/dcart.f
+ http://wwwuser.gwdg.de/~ggroenh/qmmm/mopac/gmxmop.f"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux"
+IUSE="gmxmopac7 static-libs"
+
+DEPEND="dev-libs/libf2c"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Install the executable
+ sed -i \
+ -e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
+ fortran/Makefile.am \
+ || die "sed failed: install mopac7"
+ # Install the script to run the executable
+ sed -i \
+ -e "s:EXTRA_DIST = autogen.sh run_mopac7:bin_SCRIPTS = run_mopac7:g" \
+ Makefile.am \
+ || die "sed failed: install run_mopac7"
+
+ eautoreconf
+}
+
+src_configure() {
+ #set -std=legacy -fno-automatic according to
+ #http://www.bioinformatics.org/pipermail/ghemical-devel/2008-August/000763.html
+ FFLAGS="${FFLAGS} -std=legacy -fno-automatic" econf
+}
+
+src_compile() {
+ emake
+ if use gmxmopac7; then
+ einfo "Making mopac7 lib for gromacs"
+ mkdir "${S}"/fortran/libgmxmopac7 && cd "${S}"/fortran/libgmxmopac7
+ cp -f ../SIZES ../*.f "${FILESDIR}"/Makefile . || die
+ emake clean
+ cp -f "${DISTDIR}"/gmxmop.f "${DISTDIR}"/dcart.f . || die
+ sed "s:GENTOOVERSION:${PV}:g" -i Makefile
+ emake FC=$(tc-getFC)
+ if use static-libs; then
+ emake static
+ fi
+ fi
+}
+
+src_install() {
+ # A correct fix would have a run_mopac7.in with @bindir@ that gets
+ # replaced by configure, and run_mopac7 added to AC_OUTPUT in configure.ac
+ sed -i "s:./fortran/mopac7:mopac7:g" run_mopac7
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog
+ if use gmxmopac7; then
+ cd "${S}"/fortran/libgmxmopac7
+ dolib.so libgmxmopac7.so*
+ if use static-libs; then
+ dolib.a libgmxmopac7.a
+ fi
+ fi
+}