summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-27 05:42:13 +0000
committerSam James <sam@gentoo.org>2024-11-27 05:42:13 +0000
commitdba12e8bc099ccde5c329af38d33e1ff17bead8a (patch)
tree2b75b533e500a6232769a14c362337731889791e /sci-calculators
parentapp-admin/sudo: add 1.9.16_p2 (diff)
downloadgentoo-dba12e8bc099ccde5c329af38d33e1ff17bead8a.tar.gz
gentoo-dba12e8bc099ccde5c329af38d33e1ff17bead8a.tar.bz2
gentoo-dba12e8bc099ccde5c329af38d33e1ff17bead8a.zip
sci-calculators/units: add 2.24
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/units-2.24.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index 0dcbf6be4c02..d779dc3302dc 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1 +1,2 @@
DIST units-2.23.tar.gz 1423494 BLAKE2B 9a835ec3862b7c09149d5726084fb3068acb9d01b3a8234647cd47805a559b75131046bfe407152dec9f2e06c6c3315686dd0db0694d2c5ef0173e6ee64ce378 SHA512 628aac3a560ed728f1aba91841f9fccc0b145375a0b8953b98ac00c71bcc7f647377d16c6ba7b59e987a6e7a74b44038a62f2576f757a43d7564be469be81ee8
+DIST units-2.24.tar.gz 1493600 BLAKE2B e3f31b212dde2cd438f2ce40bef7ab413c18fb36ad2ab233fe62c6fb3f424f99f9c1878cd86239bc476d7805bf418ce1c2821b3b03b1a0e81cffa9b83e05ced2 SHA512 cf0a5f3ad410ff3eeaabfac71f5570b1eed9014c0a76afb6e6f3059b5eb3184cb577f9f76b1c5acd3a1aa8beb12ad060af5af00eef8361d68a7a19697486540f
diff --git a/sci-calculators/units/units-2.24.ebuild b/sci-calculators/units/units-2.24.ebuild
new file mode 100644
index 000000000000..e70c55546e81
--- /dev/null
+++ b/sci-calculators/units/units-2.24.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit flag-o-matic python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units-cur? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.20-readerror.patch
+)
+
+DOCS=( NEWS README )
+
+src_configure() {
+ # bug #944371
+ append-cflags -std=gnu17
+
+ local myconf=(
+ --sharedstatedir="${EPREFIX}"/var/lib
+ ac_cv_path_PYTHON=no
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ default
+
+ if use units-cur; then
+ sed \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_foreach_impl python_doscript units_cur
+ fi
+}