summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-26 16:48:38 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-26 16:48:38 +0100
commit7ac63d7e4634475751415583dc95dedc4700a653 (patch)
tree98f5859cb18de833ef2227b06d1bf4515db6e717 /sci-calculators
parentsci-geosciences/mtkbabel: update EAPI 6 -> 8 (diff)
downloadgentoo-7ac63d7e4634475751415583dc95dedc4700a653.tar.gz
gentoo-7ac63d7e4634475751415583dc95dedc4700a653.tar.bz2
gentoo-7ac63d7e4634475751415583dc95dedc4700a653.zip
sci-calculators/tiemu: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/tiemu/tiemu-3.03-r2.ebuild (renamed from sci-calculators/tiemu/tiemu-3.03-r1.ebuild)17
1 files changed, 10 insertions, 7 deletions
diff --git a/sci-calculators/tiemu/tiemu-3.03-r1.ebuild b/sci-calculators/tiemu/tiemu-3.03-r2.ebuild
index 62b0cee3d4f5..ef5c95e0d072 100644
--- a/sci-calculators/tiemu/tiemu-3.03-r1.ebuild
+++ b/sci-calculators/tiemu/tiemu-3.03-r2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit desktop
DESCRIPTION="Texas Instruments hand-helds emulator"
@@ -13,21 +14,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="dbus nls sdl threads xinerama"
-RDEPEND="sci-libs/libticables2
+RDEPEND="
+ gnome-base/libglade:2.0
+ sci-libs/libticables2
sci-libs/libticalcs2
sci-libs/libtifiles2
sci-libs/libticonv
- gnome-base/libglade:2.0
x11-libs/gtk+:2
dbus? ( >=dev-libs/dbus-glib-0.60 )
nls? ( virtual/libintl )
sdl? ( media-libs/libsdl )
xinerama? ( x11-libs/libXinerama )"
-
DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
xinerama? ( x11-base/xorg-proto )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${P}-remove_depreciated_gtk_calls.patch
@@ -57,7 +59,8 @@ src_configure() {
src_install() {
default
- rm -f "${ED%/}"/usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES} || die
+
+ rm -f "${ED}"/usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES} || die
make_desktop_entry tiemu "TiEmu Calculator" \
"${EPREFIX}"/usr/share/tiemu/pixmaps/icon.xpm
}