summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-29 00:09:09 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-29 00:09:09 +0100
commit2a1d01a2d1aff43310a0bf5337fcfffdaef00914 (patch)
tree34b176bcdb7775a4e5bf04e509004c57630be9be /sci-calculators
parentnet-proxy/ziproxy: port to EAPI 7 and GLEP 81 (diff)
downloadgentoo-2a1d01a2d1aff43310a0bf5337fcfffdaef00914.tar.gz
gentoo-2a1d01a2d1aff43310a0bf5337fcfffdaef00914.tar.bz2
gentoo-2a1d01a2d1aff43310a0bf5337fcfffdaef00914.zip
sci-calculators/hcalc: port to EAPI 7
* Thanks to Jeroen Roovers for submitting the patch. Closes: https://bugs.gentoo.org/709722 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/hcalc/files/hcalc-1.2-fno-common.patch13
-rw-r--r--sci-calculators/hcalc/hcalc-1.2-r1.ebuild9
2 files changed, 18 insertions, 4 deletions
diff --git a/sci-calculators/hcalc/files/hcalc-1.2-fno-common.patch b/sci-calculators/hcalc/files/hcalc-1.2-fno-common.patch
new file mode 100644
index 000000000000..b8bdcc73e305
--- /dev/null
+++ b/sci-calculators/hcalc/files/hcalc-1.2-fno-common.patch
@@ -0,0 +1,13 @@
+--- a/hcalc.h
++++ b/hcalc.h
+@@ -25,8 +25,8 @@
+ extern Pixmap face;
+ extern Pixmap chars;
+
+-int bit_on;
+-int bit_off;
++extern int bit_on;
++extern int bit_off;
+
+ extern int char_to_x[256];
+ extern char charmap[];
diff --git a/sci-calculators/hcalc/hcalc-1.2-r1.ebuild b/sci-calculators/hcalc/hcalc-1.2-r1.ebuild
index bbd0de3fcfac..6a6b90666a0a 100644
--- a/sci-calculators/hcalc/hcalc-1.2-r1.ebuild
+++ b/sci-calculators/hcalc/hcalc-1.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="DJ's Hex Calculator"
HOMEPAGE="http://www.delorie.com/store/hcalc/ https://github.com/jlec/hcalc"
@@ -12,13 +12,14 @@ SRC_URI="https://github.com/downloads/jlec/hcalc/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="
x11-libs/libX11
x11-libs/libXpm"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
pkg_postinst() {
einfo "Enter hcalc to run and use kill or ctrl-c to exit."
}