summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-08-22 21:37:25 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-22 21:37:25 +0200
commit6a6b5309daa23e0dbb6318512e68e81ffa668c81 (patch)
tree7c973ffc5ba55cb53cc14418b7a7df1102805c36 /sci-biology
parentsci-libs/profnet: Port to EAPI 7 (diff)
downloadgentoo-6a6b5309daa23e0dbb6318512e68e81ffa668c81.tar.gz
gentoo-6a6b5309daa23e0dbb6318512e68e81ffa668c81.tar.bz2
gentoo-6a6b5309daa23e0dbb6318512e68e81ffa668c81.zip
sci-biology/wise: Port to EAPI 8
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/wise/files/wise-api.tex.patch38
-rw-r--r--sci-biology/wise/wise-2.4.0_alpha-r1.ebuild71
-rw-r--r--sci-biology/wise/wise-2.4.0_alpha.ebuild73
3 files changed, 109 insertions, 73 deletions
diff --git a/sci-biology/wise/files/wise-api.tex.patch b/sci-biology/wise/files/wise-api.tex.patch
new file mode 100644
index 000000000000..d6d56888dfb3
--- /dev/null
+++ b/sci-biology/wise/files/wise-api.tex.patch
@@ -0,0 +1,38 @@
+--- a/api.tex.old
++++ b/api.tex
+@@ -204,7 +204,7 @@
+ \item Build two Sequence objects, from a file or strings (\ref{object_Sequence})
+ \item Optionally convert the Sequence objects into Protein objects (\ref{object_Protein}). This ensures you have proteins
+ \item Read in the comparison matrix using CompMat (\ref{object_CompMat})
+-\item Use one of the algorithm calls in sw_wrap module (\ref{module_sw_wrap})
++\item Use one of the algorithm calls in sw\_wrap module (\ref{module_sw_wrap})
+ \item Show the alignment using a call in the seqaligndisaply module (\ref{module_seqaligndisplay})
+ \end{itemize}
+
+@@ -213,7 +213,7 @@
+ \item Read in a sequence object and convert it to a protein object (\ref{object_Protein},\ref{object_Sequence})
+ \item Make a protein database from the single protein object (\ref{object_ProteinDB})
+ \item Make a protein database from a single fasta file (\ref{object_ProteinDB})
+-\item Using one of the calls to the sw_wrap module, make a Hscore object (\ref{module_sw_wrap})
++\item Using one of the calls to the sw\_wrap module, make a Hscore object (\ref{module_sw_wrap})
+ \item Show the Hscore object using a show function (\ref{object_Hscore})
+ \item Retrieve individual protein objects from the database by taking out the
+ DataEntry objects (\ref{object_DataEntry}) and passing them into the ProteinDB object (\ref{object_ProteinDB}), giving you a protein object
+@@ -232,7 +232,7 @@
+ \item Read in a codon table (\ref{object_CodonTable})
+ \item Make a random DNA model (\ref{object_RandomModelDNA})
+ \item Make an algorithm type (\ref{module_gwrap})
+-\item Build an entire parameter set for genewise using Wise2::GeneParameter21_wrap (\ref{module_gwrap})
++\item Build an entire parameter set for genewise using Wise2::GeneParameter21\_wrap (\ref{module_gwrap})
+ \item Run the actual algorithm (\ref{module_gwrap})
+ \item show the alignment using genedisplay (\ref{module_gwrap})
+ \end{itemize}
+@@ -5055,7 +5055,7 @@
+ Member functions of RandomModel
+
+ \section{sequence\_codon}
+-\label{module_sequence\_codon}
++\label{module_sequence_codon}
+ This module only contains factory methods
+
+ \subsection{sequence\_codon factory methods}
diff --git a/sci-biology/wise/wise-2.4.0_alpha-r1.ebuild b/sci-biology/wise/wise-2.4.0_alpha-r1.ebuild
new file mode 100644
index 000000000000..a033ffd011bb
--- /dev/null
+++ b/sci-biology/wise/wise-2.4.0_alpha-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PV/_}"
+MY_P="${PN}${MY_PV}"
+DESCRIPTION="Intelligent algorithms for DNA searches"
+HOMEPAGE="http://www.ebi.ac.uk/Wise2/"
+SRC_URI="
+ ftp://ftp.ebi.ac.uk/pub/software/${PN}2/${MY_P}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/${P}-patchset.tar.bz2
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="~sci-biology/hmmer-2.3.2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-shells/tcsh
+ dev-lang/perl
+ virtual/latex-base
+"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-patchset/${P}-glibc-2.10.patch
+ "${WORKDIR}"/${P}-patchset/${P}-cflags.patch
+)
+
+src_prepare() {
+ default
+ cd docs || die
+ cat ../src/models/*.tex ../src/dynlibsrc/*.tex | perl gettex.pl > temp.tex || die
+ cat wise2api.tex temp.tex apiend.tex > api.tex || die
+ eapply "${FILESDIR}"/${PN}-api.tex.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake -C src all
+
+ if use doc; then
+ cd docs || die
+ for i in api appendix dynamite wise2 wise3arch; do
+ latex ${i} || die
+ latex ${i} || die
+ dvips ${i}.dvi -o || die
+ done
+ fi
+}
+
+src_test() {
+ cd src || die
+ WISECONFIGDIR="${S}/wisecfg" emake test
+}
+
+src_install() {
+ dobin src/bin/* src/dynlibsrc/testgendb
+
+ insinto /usr/share/${PN}
+ doins -r wisecfg
+
+ use doc && dodoc docs/*.ps
+ newenvd "${WORKDIR}"/${P}-patchset/${PN}-env 24wise
+}
diff --git a/sci-biology/wise/wise-2.4.0_alpha.ebuild b/sci-biology/wise/wise-2.4.0_alpha.ebuild
deleted file mode 100644
index c37a8972e84e..000000000000
--- a/sci-biology/wise/wise-2.4.0_alpha.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit epatch toolchain-funcs versionator
-
-DESCRIPTION="Intelligent algorithms for DNA searches"
-HOMEPAGE="http://www.ebi.ac.uk/Wise2/"
-SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/${PN}2/${PN}$(delete_version_separator 3).tar.gz
- https://dev.gentoo.org/~mgorny/dist/${P}-patchset.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc static-libs"
-
-RDEPEND="~sci-biology/hmmer-2.3.2"
-DEPEND="
- ${RDEPEND}
- app-shells/tcsh
- dev-lang/perl
- virtual/latex-base"
-
-S="${WORKDIR}"/${PN}$(delete_version_separator 3)
-
-src_prepare() {
- epatch \
- "${WORKDIR}"/${P}-patchset/${P}-glibc-2.10.patch \
- "${WORKDIR}"/${P}-patchset/${P}-cflags.patch
- cd "${S}"/docs || die
- cat "${S}"/src/models/*.tex "${S}"/src/dynlibsrc/*.tex | perl gettex.pl > temp.tex || die
- cat wise2api.tex temp.tex apiend.tex > api.tex || die
- epatch "${WORKDIR}"/${P}-patchset/${PN}-api.tex.patch
-}
-
-src_compile() {
- emake \
- -C src \
- CC="$(tc-getCC)" \
- all
- if use doc; then
- cd "${S}"/docs || die
- for i in api appendix dynamite wise2 wise3arch; do
- latex ${i} || die
- latex ${i} || die
- dvips ${i}.dvi -o || die
- done
- fi
-}
-
-src_test() {
- cd "${S}"/src || die
- WISECONFIGDIR="${S}/wisecfg" emake test
-}
-
-src_install() {
- dobin "${S}"/src/bin/* "${S}"/src/dynlibsrc/testgendb
- use static-libs && \
- dolib.a \
- "${S}"/src/base/libwisebase.a \
- "${S}"/src/dynlibsrc/libdyna.a \
- "${S}"/src/models/libmodel.a
-
- insinto /usr/share/${PN}
- doins -r "${S}"/wisecfg
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins "${S}"/docs/*.ps
- fi
- newenvd "${WORKDIR}"/${P}-patchset/${PN}-env 24wise || die "Failed to install env file"
-}