summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/trnascan-se/trnascan-se-1.31.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/trnascan-se/trnascan-se-1.31.ebuild')
-rw-r--r--sci-biology/trnascan-se/trnascan-se-1.31.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-biology/trnascan-se/trnascan-se-1.31.ebuild b/sci-biology/trnascan-se/trnascan-se-1.31.ebuild
new file mode 100644
index 000000000000..aa9b3a03fd8f
--- /dev/null
+++ b/sci-biology/trnascan-se/trnascan-se-1.31.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+
+inherit eutils perl-module toolchain-funcs
+
+DESCRIPTION="tRNA detection in large-scale genome sequences"
+HOMEPAGE="http://lowelab.ucsc.edu/tRNAscan-SE/"
+SRC_URI="http://lowelab.ucsc.edu/software/tRNAscan-SE.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/tRNAscan-SE-1.3.1/
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed \
+ -e "s:BINDIR = \$(HOME)/bin:BINDIR = ${EPREFIX}/usr/bin:" \
+ -e "s:LIBDIR = \$(HOME)/lib/tRNAscan-SE:LIBDIR = ${EPRFIX}/usr/share/${PN}:" \
+ -e "s:MANDIR = \$(HOME)/man:MANDIR = ${EPREFIX}/usr/share/man:" \
+ -e "s:CC = gcc:CC = $(tc-getCC):" \
+ -e "s:CFLAGS = -O:CFLAGS = ${CFLAGS}:" \
+ -i Makefile || die
+
+ perl_set_version
+}
+
+src_test() {
+ emake PATH="${S}:${PATH}" testrun
+}
+
+src_install() {
+ dobin covels-SE coves-SE eufindtRNA tRNAscan-SE trnascan-1.4
+
+ newman tRNAscan-SE.man tRNAscan-SE.man.1
+
+ dodoc MANUAL README Release.history
+
+ insinto /usr/share/${PN}/
+ doins *.cm gcode.* Dsignal TPCsignal
+
+ dodoc Manual.ps
+
+ insinto ${VENDOR_LIB}
+ doins -r tRNAscanSE
+}