summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/psipred/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/psipred/files')
-rw-r--r--sci-biology/psipred/files/2.6.1-Makefile.patch42
-rw-r--r--sci-biology/psipred/files/2.6.1-path.patch34
-rw-r--r--sci-biology/psipred/files/3.0-path.patch38
-rw-r--r--sci-biology/psipred/files/3.1-Makefile.patch38
-rw-r--r--sci-biology/psipred/files/3.1-fgets.patch13
-rw-r--r--sci-biology/psipred/files/3.1-path.patch38
-rw-r--r--sci-biology/psipred/files/3.2-fgets.patch13
7 files changed, 216 insertions, 0 deletions
diff --git a/sci-biology/psipred/files/2.6.1-Makefile.patch b/sci-biology/psipred/files/2.6.1-Makefile.patch
new file mode 100644
index 000000000000..0a6df743ec83
--- /dev/null
+++ b/sci-biology/psipred/files/2.6.1-Makefile.patch
@@ -0,0 +1,42 @@
+--- src/Makefile 2008-03-09 22:59:51.000000000 +0100
++++ src/Makefile.new 2009-04-09 12:31:38.669457918 +0200
+@@ -6,9 +6,7 @@
+ #### CFLAGS Flags to pass to C compiler.
+
+ INCDIR = .
+-CC = cc
+
+-CFLAGS = -O
+ LIBS = -lm
+
+ all: psipred psipass2 seq2mtx pfilt
+@@ -20,13 +18,13 @@
+ /bin/rm -f psipred psipass2 seq2mtx pfilt
+
+ psipred: sspred_avpred.c ssdefs.h sspred_net.h
+- $(CC) $(CFLAGS) sspred_avpred.c $(LIBS) -o psipred
++ $(CC) $(CFLAGS) $(LDFLAGS) sspred_avpred.c $(LIBS) -o psipred
+
+ psipass2: sspred_hmulti.c ssdefs.h sspred_net2.h
+- $(CC) $(CFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
++ $(CC) $(CFLAGS) $(LDFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
+
+ seq2mtx: seq2mtx.c
+- $(CC) $(CFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
++ $(CC) $(CFLAGS) $(LDFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
+
+ pfilt: pfilt.c
+- $(CC) $(CFLAGS) pfilt.c $(LIBS) -o pfilt
++ $(CC) $(CFLAGS) $(LDFLAGS) pfilt.c $(LIBS) -o pfilt
+--- src/Makefile 2009-04-09 12:34:41.636939862 +0200
++++ src/Makefile.new 2009-04-09 12:36:03.796098341 +0200
+@@ -12,7 +12,8 @@
+ all: psipred psipass2 seq2mtx pfilt
+
+ install:
+- /bin/cp psipred psipass2 seq2mtx pfilt ../bin
++ /bin/mkdir -p $(DESTDIR)/usr/bin
++ /bin/cp psipred psipass2 seq2mtx pfilt $(DESTDIR)/usr/bin
+
+ clean:
+ /bin/rm -f psipred psipass2 seq2mtx pfilt
diff --git a/sci-biology/psipred/files/2.6.1-path.patch b/sci-biology/psipred/files/2.6.1-path.patch
new file mode 100644
index 000000000000..9b8d6b9fecfa
--- /dev/null
+++ b/sci-biology/psipred/files/2.6.1-path.patch
@@ -0,0 +1,34 @@
+--- runpsipred 2008-04-05 00:14:36.000000000 +0200
++++ runpsipred.new 2009-04-09 12:40:46.376203036 +0200
+@@ -14,13 +14,13 @@
+ set dbname = nr
+
+ # Where the NCBI programs have been installed
+-set ncbidir = /usr/local/bin
++set ncbidir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V2 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V2 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
+--- runpsipred_single 2008-04-05 00:14:38.000000000 +0200
++++ runpsipred_single.new 2009-04-09 12:41:10.086067082 +0200
+@@ -10,10 +10,10 @@
+ # NOTE: Script modified to be more cluster friendly (DTJ April 2008)
+
+ # Where the PSIPRED V2 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V2 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
diff --git a/sci-biology/psipred/files/3.0-path.patch b/sci-biology/psipred/files/3.0-path.patch
new file mode 100644
index 000000000000..ebf9b2a61f4e
--- /dev/null
+++ b/sci-biology/psipred/files/3.0-path.patch
@@ -0,0 +1,38 @@
+diff --git a/runpsipred b/runpsipred
+index e133686..6ad57cc 100755
+--- a/runpsipred
++++ b/runpsipred
+@@ -14,13 +14,13 @@
+ set dbname = uniref90
+
+ # Where the NCBI programs have been installed
+-set ncbidir = /usr/local/bin
++set ncbidir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V3 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V3 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
+diff --git a/runpsipred_single b/runpsipred_single
+index 1f7680b..7bd5bc3 100755
+--- a/runpsipred_single
++++ b/runpsipred_single
+@@ -10,10 +10,10 @@
+ # NOTE: Script modified to be more cluster friendly (DTJ April 2008)
+
+ # Where the PSIPRED V3 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V3 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
diff --git a/sci-biology/psipred/files/3.1-Makefile.patch b/sci-biology/psipred/files/3.1-Makefile.patch
new file mode 100644
index 000000000000..0c70b6868565
--- /dev/null
+++ b/sci-biology/psipred/files/3.1-Makefile.patch
@@ -0,0 +1,38 @@
+diff --git a/src/Makefile b/src/Makefile
+index abed8af..26061fa 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -6,9 +6,9 @@
+ #### CFLAGS Flags to pass to C compiler.
+
+ INCDIR = .
+-CC = cc
++CC ?= gcc
+
+-CFLAGS = -O
++CFLAGS ?= -O2
+ LIBS = -lm
+
+ all: psipred psipass2 chkparse seq2mtx pfilt
+@@ -20,16 +20,16 @@ clean:
+ /bin/rm -f psipred psipass2 chkparse seq2mtx pfilt
+
+ psipred: sspred_avpred.c ssdefs.h sspred_net.h
+- $(CC) $(CFLAGS) sspred_avpred.c $(LIBS) -o psipred
++ $(CC) $(CFLAGS) $(LDFLAGS) sspred_avpred.c $(LIBS) -o psipred
+
+ psipass2: sspred_hmulti.c ssdefs.h sspred_net2.h
+- $(CC) $(CFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
++ $(CC) $(CFLAGS) $(LDFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
+
+ chkparse: chkparse.c
+- $(CC) $(CFLAGS) chkparse.c $(LIBS) -o chkparse
++ $(CC) $(CFLAGS) $(LDFLAGS) chkparse.c $(LIBS) -o chkparse
+
+ seq2mtx: seq2mtx.c
+- $(CC) $(CFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
++ $(CC) $(CFLAGS) $(LDFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
+
+ pfilt: pfilt.c
+- $(CC) $(CFLAGS) pfilt.c $(LIBS) -o pfilt
++ $(CC) $(CFLAGS) $(LDFLAGS) pfilt.c $(LIBS) -o pfilt
diff --git a/sci-biology/psipred/files/3.1-fgets.patch b/sci-biology/psipred/files/3.1-fgets.patch
new file mode 100644
index 000000000000..e58d677258e0
--- /dev/null
+++ b/sci-biology/psipred/files/3.1-fgets.patch
@@ -0,0 +1,13 @@
+diff --git a/src/sspred_avpred.c b/src/sspred_avpred.c
+index 4d8e5ff..0d82483 100644
+--- a/src/sspred_avpred.c
++++ b/src/sspred_avpred.c
+@@ -213,7 +213,7 @@ predict(int argc, char **argv)
+ int getmtx(FILE *lfil)
+ {
+ int aa, i, j, naa;
+- char buf[256], *p;
++ char buf[65536], *p;
+
+ if (fscanf(lfil, "%d", &naa) != 1)
+ fail("Bad mtx file - no sequence length!");
diff --git a/sci-biology/psipred/files/3.1-path.patch b/sci-biology/psipred/files/3.1-path.patch
new file mode 100644
index 000000000000..564e9c8a1ef9
--- /dev/null
+++ b/sci-biology/psipred/files/3.1-path.patch
@@ -0,0 +1,38 @@
+diff --git a/runpsipred b/runpsipred
+index 4ccf44e..34dee99 100755
+--- a/runpsipred
++++ b/runpsipred
+@@ -14,13 +14,13 @@
+ set dbname = uniref90filt
+
+ # Where the NCBI programs have been installed
+-set ncbidir = /usr/local/bin
++set ncbidir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V2 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V2 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
+diff --git a/runpsipred_single b/runpsipred_single
+index 1f7680b..7bd5bc3 100755
+--- a/runpsipred_single
++++ b/runpsipred_single
+@@ -10,10 +10,10 @@
+ # NOTE: Script modified to be more cluster friendly (DTJ April 2008)
+
+ # Where the PSIPRED V3 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V3 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
diff --git a/sci-biology/psipred/files/3.2-fgets.patch b/sci-biology/psipred/files/3.2-fgets.patch
new file mode 100644
index 000000000000..ec06d141ee34
--- /dev/null
+++ b/sci-biology/psipred/files/3.2-fgets.patch
@@ -0,0 +1,13 @@
+diff --git a/src/sspred_avpred.c b/src/sspred_avpred.c
+index 37b1332..4f04ab6 100644
+--- a/src/sspred_avpred.c
++++ b/src/sspred_avpred.c
+@@ -223,7 +223,7 @@ predict(int argc, char **argv)
+ int getmtx(FILE *lfil)
+ {
+ int aa, i, j, naa;
+- char buf[256], *p;
++ char buf[65536], *p;
+
+ if (fscanf(lfil, "%d", &naa) != 1)
+ fail("Bad mtx file - no sequence length!");