summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/embassy-mse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/embassy-mse')
-rw-r--r--sci-biology/embassy-mse/Manifest3
-rw-r--r--sci-biology/embassy-mse/embassy-mse-1.0.0-r6.ebuild19
-rw-r--r--sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild25
-rw-r--r--sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch149
-rw-r--r--sci-biology/embassy-mse/metadata.xml5
5 files changed, 201 insertions, 0 deletions
diff --git a/sci-biology/embassy-mse/Manifest b/sci-biology/embassy-mse/Manifest
new file mode 100644
index 000000000000..15e2c00a0f43
--- /dev/null
+++ b/sci-biology/embassy-mse/Manifest
@@ -0,0 +1,3 @@
+DIST EMBOSS-6.0.1.tar.gz 20204153 SHA256 3e352902aa9dab88bf486457ff23794f19398dfc6b550c4bf175dfcad34c233d
+DIST embassy-6.0.1-mse-1.0.0.tar.gz 445562 SHA256 9e3688ff3514b7ea6cf104fbd2a2e611fe726fb7ac4bebab6f3c103f05c08d90
+DIST embassy-mse-3.0.0.650.tar.gz 491747 SHA256 2744c2a447cc16d7ad4d9049c61793fc2803659b83b0666b3ca9c30648dac88c SHA512 4ae34de71566464e4352ff7b3bbd19b8bf0571013f34253495cf5cc57240bac9c75192c302eb0231763db1745a7e3e79ebcdcb006e36ea4621a886b213eb96d3 WHIRLPOOL 8d257e79161d5989ac2fe3fe5e55e073402b57795121693fd43ac0d2d348032abb7927d4e40faf2b4db182145f9bcdcc7ba5d7b0534df10dd844c256b8dacb9b
diff --git a/sci-biology/embassy-mse/embassy-mse-1.0.0-r6.ebuild b/sci-biology/embassy-mse/embassy-mse-1.0.0-r6.ebuild
new file mode 100644
index 000000000000..8767aee8f8d3
--- /dev/null
+++ b/sci-biology/embassy-mse/embassy-mse-1.0.0-r6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EBOV="6.0.1"
+
+inherit embassy
+
+DESCRIPTION="EMBOSS integrated version of MSE - Multiple Sequence Screen Editor"
+SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/old/${EBOV}/EMBOSS-${EBOV}.tar.gz
+ mirror://gentoo/embassy-${EBOV}-${PN:8}-${PV}.tar.gz"
+
+KEYWORDS="amd64 ~ppc x86"
+
+src_install() {
+ embassy_src_install
+ insinto /usr/include/emboss/mse
+ doins h/*.h
+}
diff --git a/sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild b/sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild
new file mode 100644
index 000000000000..32b6410620e1
--- /dev/null
+++ b/sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EBO_DESCRIPTION="MSE - Multiple Sequence Screen Editor"
+EBO_EXTRA_ECONF="$(use_enable ncurses curses)"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit emboss-r1
+
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos"
+IUSE+=" ncurses"
+
+RDEPEND+=" ncurses? ( sys-libs/ncurses )"
+
+PATCHES=( "${FILESDIR}"/${P}_fix-build-system.patch )
+
+src_install() {
+ autotools-utils_src_install
+ insinto /usr/include/emboss/mse
+ doins h/*.h
+}
diff --git a/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch b/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch
new file mode 100644
index 000000000000..c1095b266d60
--- /dev/null
+++ b/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch
@@ -0,0 +1,149 @@
+ ckit/Makefile.am | 2 +-
+ configure.ac | 67 +++++++++++---------------------------------------
+ emboss_acd/Makefile.am | 2 +-
+ src/Makefile.am | 6 ++---
+ 4 files changed, 18 insertions(+), 59 deletions(-)
+
+diff --git a/ckit/Makefile.am b/ckit/Makefile.am
+index f87b131..a670d2b 100644
+--- a/ckit/Makefile.am
++++ b/ckit/Makefile.am
+@@ -2,7 +2,7 @@
+
+ lib_LTLIBRARIES = libckit.la
+
+-AM_CPPFLAGS = -I../h
++AM_CPPFLAGS = -I$(top_srcdir)/h
+
+ CKITSRC = datafiles.c next.c seqentry.c strings.c gcg.c pir.c \
+ seqspec.c ttyinterface.c nextseqentry.c \
+diff --git a/configure.ac b/configure.ac
+index a20d488..eb208bf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -635,33 +635,6 @@ AS_CASE([${host_os}],
+
+
+
+-dnl PCRE library definitions - see the MAJOR and MINOR values
+-dnl to see which version's configure.in these lines come from
+-
+-dnl Provide the current PCRE version information. Do not use numbers
+-dnl with leading zeros for the minor version, as they end up in a C
+-dnl macro, and may be treated as octal constants. Stick to single
+-dnl digits for minor numbers less than 10. There are unlikely to be
+-dnl that many releases anyway.
+-
+-PCRE_MAJOR="7"
+-PCRE_MINOR="9"
+-PCRE_DATE="11-Apr-2009"
+-PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
+-
+-dnl Default values for miscellaneous macros
+-
+-POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
+-
+-dnl Provide versioning information for libtool shared libraries that
+-dnl are built by default on Unix systems.
+-
+-PCRE_LIB_VERSION="0:1:0"
+-PCRE_POSIXLIB_VERSION="0:0:0"
+-
+-
+-
+-
+ dnl FIXME: This does no longer seem required with Autoconf 2.67?
+ dnl Intel MacOSX 10.6 puts X11 in a non-standard place
+ dnl AS_IF([test "x${with_x}" != "xno"],
+@@ -737,21 +710,6 @@ AX_LIB_POSTGRESQL
+
+
+
+-dnl "Export" these variables for PCRE
+-
+-AC_SUBST([HAVE_MEMMOVE])
+-AC_SUBST([HAVE_STRERROR])
+-AC_SUBST([PCRE_MAJOR])
+-AC_SUBST([PCRE_MINOR])
+-AC_SUBST([PCRE_DATE])
+-AC_SUBST([PCRE_VERSION])
+-AC_SUBST([PCRE_LIB_VERSION])
+-AC_SUBST([PCRE_POSIXLIB_VERSION])
+-AC_SUBST([POSIX_MALLOC_THRESHOLD])
+-
+-
+-
+-
+ dnl Test if --enable-localforce given
+ locallink="no"
+ embprefix="/usr/local"
+@@ -874,6 +832,13 @@ AC_ARG_ENABLE([systemlibs],
+ AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+
+
++AS_IF([test "x${enable_systemlibs}" = "xyes"],
++[
++dnl using system libraries
++ PKG_CHECK_MODULES([PLPLOT], [plplotd],
++ [],[PKG_CHECK_MODULES([PLPLOT], [plplot])]
++ )
++])
+
+
+ # Enable the purify tool: --enable-purify, sets CC and LIBTOOL
+@@ -1000,17 +965,13 @@ AS_IF([test "x${enable_savestats}" = "xyes"],
+
+
+
+-dnl emnu and mse only: uses curses
+-dnl Test if --with-curses is given
+-AC_ARG_WITH([curses],
+- [AS_HELP_STRING([--with-curses],
+- [curses (or ncurses)])])
+-if test "${with_curses}" ; then
+-AC_MSG_CHECKING([for curses])
+-CPPFLAGS="$CPPFLAGS -I${with_curses}/include -I${with_curses}/include/ncurses"
+-LDFLAGS="$LDFLAGS -L${with_curses}/lib"
+-fi
+-AC_CHECK_LIB(ncurses, main, LIBS="$LIBS -lncurses", LIBS="$LIBS -lcurses")
++dnl Test if --enable-curses is given
++AC_ARG_ENABLE([curses],
++[AS_HELP_STRING([--enable-curses], [curses])])
++
++AS_IF([test "x$enable_curses" = "xyes"], [
++ PKG_CHECK_MODULES([NCURSES], [ncurses])
++])
+
+
+
+diff --git a/emboss_acd/Makefile.am b/emboss_acd/Makefile.am
+index e1c1878..e253c95 100644
+--- a/emboss_acd/Makefile.am
++++ b/emboss_acd/Makefile.am
+@@ -1,3 +1,3 @@
+
+-pkgdata_DATA = *.acd
++pkgdata_DATA = $(srcdir)/*.acd
+ pkgdatadir=$(prefix)/share/EMBOSS/acd
+diff --git a/src/Makefile.am b/src/Makefile.am
+index b44632a..84e89b5 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -18,9 +18,7 @@ AM_CPPFLAGS = -I../h \
+ -I../../../ajax/ensembl -I../../../ajax/ajaxdb \
+ -I../../../ajax/acd -I../../../plplot
+ else
+-AM_CPPFLAGS = -I../h -I${embprefix}/include \
+- -I${embprefix}/include/eplplot -I${embprefix}/include/epcre \
+- $(NLINCLUDES)
++AM_CPPFLAGS = -I$(top_srcdir)/h -I${embprefix}/include $(NLINCLUDES) $(PLPLOT_CFLAGS) $(NCURSES_CFLAGS)
+ endif
+
+ if ISSHARED
+@@ -60,5 +58,5 @@ LDADD = ../ckit/libckit.la \
+ $(XLIB)
+ else
+ LDADD = ../ckit/libckit.la -L${embprefix}/lib -lnucleus -lacd -lajaxdb \
+- -lensembl -lajaxg -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++ -lensembl -lajaxg -lajax $(NLADD) $(NCURSES_LIBS) $(XLIB)
+ endif
diff --git a/sci-biology/embassy-mse/metadata.xml b/sci-biology/embassy-mse/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/embassy-mse/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>