summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenny Page <dennypage@me.com>2024-06-29 12:10:03 -0700
committerPacho Ramos <pacho@gentoo.org>2024-07-30 23:11:51 +0200
commitdd10b638cde59af89080f5bfc1a1252a843459fb (patch)
tree85fcbd24b45ea834abd3d27b928a4c603387a157 /sci-astronomy
parentnet-wireless/liblms7002m: sync live ebuild (diff)
downloadgentoo-dd10b638cde59af89080f5bfc1a1252a843459fb.tar.gz
gentoo-dd10b638cde59af89080f5bfc1a1252a843459fb.tar.bz2
gentoo-dd10b638cde59af89080f5bfc1a1252a843459fb.zip
sci-astronomy/pyephem: add 4.1.5
Closes: https://bugs.gentoo.org/929749 Signed-off-by: Denny Page <dennypage@me.com> Closes: https://github.com/gentoo/gentoo/pull/37364 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/Manifest1
-rw-r--r--sci-astronomy/pyephem/pyephem-4.1.5.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index d4650c08e924..db92dc150a0c 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1,2 +1,3 @@
DIST pyephem-4.1.1.gh.tar.gz 2659977 BLAKE2B e373857d3fb66e742f9db992165dbd1d50afbb6b91588f2cfcd299409d491ef1174c54a182dd59b5a8e298a07312899c8f8b5a8aaa63e6b31deb5f8b1cd3131e SHA512 2539f36b7110cacd6cf95e9ba0be26ca837a66ba81f092d4be01405029adf22478184861f46ecf09d6cd35927140874e0f0d228b06537d05f3e2eddbcb35da85
DIST pyephem-4.1.3.gh.tar.gz 2660800 BLAKE2B 272a96dfe5debe083274f911737246ea90dc15b12b141e41c018d0b4eff13e548fe1d99cfb75ea7d06d7784cd9cbce7f43149a08de051cd9e12a4b5d6a306607 SHA512 1d113e1adbe5c8175364a29ae405d80005e54a4f60d475534d6721dc51b4f58d314ad161ddaf791614fcd4b0550e4b2142f4e52ec4771ca0d1be6b10f3f8cc4d
+DIST pyephem-4.1.5.gh.tar.gz 2662791 BLAKE2B a30d3103b0d626e0316e85d1188dc2e93782fd87db6792dd6933fd9efb1b3fd7be7073486ec45c96e068b7bf9e471bf369a5867af87df5b5d50e16fc1f1a0e4c SHA512 f462df23060abacc69698e67526503302306953891c92920f77bc67d977a9691ed0d176d2743fa2c7c95cb3ff558f5e4a77fa6acff82cff243b771ed7ad095c9
diff --git a/sci-astronomy/pyephem/pyephem-4.1.5.ebuild b/sci-astronomy/pyephem/pyephem-4.1.5.ebuild
new file mode 100644
index 000000000000..93729b1d9191
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-4.1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astronomical routines for the Python programming language"
+HOMEPAGE="https://rhodesmill.org/pyephem/"
+SRC_URI="https://github.com/brandon-rhodes/pyephem/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+
+EPYTEST_DESELECT=(
+ # Can't find its test files (class not loaded properly in test env?)
+ # bug #855461
+ tests/test_jpl.py::JPLTest::runTest
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Don't install rst files by default
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ PYTHONPATH=. emake -C ephem/doc html
+ fi
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs ephem
+}
+
+src_install() {
+ use doc && HTML_DOCS=( ephem/doc/_build/html/. )
+ distutils-r1_src_install
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
+}