summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-05 17:54:09 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-05 19:31:47 +0000
commit3d71b7bebff1fd73090f63498a5f0793526574be (patch)
treef77ff9904cab2d68a340e383c641cae75c5f8d1a /sci-astronomy/gnuastro
parentnet-im/gajim: Remove vulnerable version (diff)
downloadgentoo-3d71b7bebff1fd73090f63498a5f0793526574be.tar.gz
gentoo-3d71b7bebff1fd73090f63498a5f0793526574be.tar.bz2
gentoo-3d71b7bebff1fd73090f63498a5f0793526574be.zip
sci-astronomy/gnuastro: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-astronomy/gnuastro')
-rw-r--r--sci-astronomy/gnuastro/Manifest1
-rw-r--r--sci-astronomy/gnuastro/gnuastro-0.3.ebuild50
-rw-r--r--sci-astronomy/gnuastro/metadata.xml20
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-astronomy/gnuastro/Manifest b/sci-astronomy/gnuastro/Manifest
new file mode 100644
index 000000000000..4e2fb725030a
--- /dev/null
+++ b/sci-astronomy/gnuastro/Manifest
@@ -0,0 +1 @@
+DIST gnuastro-0.3.tar.gz 4525361 SHA256 8a5bc2f977d4839f820d7423d10a6b94391a9571df97a64b9feb99a117973d81 SHA512 08556fd0de196c331cfd68e4b385fbef5c130fa9c914889367f4e3637b8dc6270a2424ef92c6641ec803c355d0577cebf3ace5ad76a7024f0414bb516338beac WHIRLPOOL 1fea9c239f896be1b931a2c7ab64041e9cdaeba95b24c76058169a7337d3c4a360b86e1d11747fe74b3af8122ed8eea719ee4db2f5601d72b67c3421ed4f1e7a
diff --git a/sci-astronomy/gnuastro/gnuastro-0.3.ebuild b/sci-astronomy/gnuastro/gnuastro-0.3.ebuild
new file mode 100644
index 000000000000..8cf56694b78f
--- /dev/null
+++ b/sci-astronomy/gnuastro/gnuastro-0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="GNU Astronomy Utilities"
+HOMEPAGE="https://www.gnu.org/software/gnuastro"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs threads"
+
+# jpeg, pdf, and libgit2 are forced deps
+# because they are automagically detected.
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ dev-libs/libgit2:=
+ sci-astronomy/wcslib:0=
+ sci-libs/cfitsio:0=
+ sci-libs/gsl:0=
+ virtual/jpeg:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e 's/-O3//' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-bin-op-alltypes
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ )
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+ use doc && emake install-html
+}
diff --git a/sci-astronomy/gnuastro/metadata.xml b/sci-astronomy/gnuastro/metadata.xml
new file mode 100644
index 000000000000..c91cdd639148
--- /dev/null
+++ b/sci-astronomy/gnuastro/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The GNU Astronomy Utilities (Gnuastro) is an official GNU package
+ consisting of various programs and library functions for the
+ manipulation and analysis of astronomical data. All the programs
+ share the same basic command-line user interface for the comfort
+ of both the users and developers. Gnuastro is written to comply
+ fully with the GNU coding standards so it integrates finely with
+ the GNU/Linux operating system. This also enables astronomers to
+ expect a fully familiar experience in the source code, building,
+ installing and command-line user interaction that they have seen
+ in all the other GNU software that they use.
+ </longdescription>
+</pkgmetadata>