summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /perl-core
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Archive-Tar/Archive-Tar-2.300.0.ebuild1
-rw-r--r--perl-core/CPAN-Meta/CPAN-Meta-2.150.1.ebuild3
-rw-r--r--perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild1
-rw-r--r--perl-core/HTTP-Tiny/HTTP-Tiny-0.43.0.ebuild3
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild3
-rw-r--r--perl-core/Scalar-List-Utils/Scalar-List-Utils-1.460.0.ebuild1
6 files changed, 9 insertions, 3 deletions
diff --git a/perl-core/Archive-Tar/Archive-Tar-2.300.0.ebuild b/perl-core/Archive-Tar/Archive-Tar-2.300.0.ebuild
index 4139e0ae2b5f..5e205e0755a5 100644
--- a/perl-core/Archive-Tar/Archive-Tar-2.300.0.ebuild
+++ b/perl-core/Archive-Tar/Archive-Tar-2.300.0.ebuild
@@ -12,6 +12,7 @@ DESCRIPTION="A Perl module for creation and manipulation of tar files"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=virtual/perl-File-Spec-0.820.0
diff --git a/perl-core/CPAN-Meta/CPAN-Meta-2.150.1.ebuild b/perl-core/CPAN-Meta/CPAN-Meta-2.150.1.ebuild
index d9b8e7482cd9..88a681e60996 100644
--- a/perl-core/CPAN-Meta/CPAN-Meta-2.150.1.ebuild
+++ b/perl-core/CPAN-Meta/CPAN-Meta-2.150.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ DESCRIPTION="The distribution metadata for a CPAN dist"
SLOT="0"
KEYWORDS=""
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=virtual/perl-CPAN-Meta-Requirements-2.121.0
diff --git a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild
index a8069605ed0c..a5419d21cb0f 100644
--- a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild
+++ b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild
@@ -10,6 +10,7 @@ DESCRIPTION="Create a module Makefile"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=virtual/perl-ExtUtils-Install-1.520.0
diff --git a/perl-core/HTTP-Tiny/HTTP-Tiny-0.43.0.ebuild b/perl-core/HTTP-Tiny/HTTP-Tiny-0.43.0.ebuild
index 919a26e0035f..c836656efce1 100644
--- a/perl-core/HTTP-Tiny/HTTP-Tiny-0.43.0.ebuild
+++ b/perl-core/HTTP-Tiny/HTTP-Tiny-0.43.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,6 +11,7 @@ LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
KEYWORDS=""
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
>=virtual/perl-ExtUtils-MakeMaker-6.30
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild
index b2782fc178e4..4fcd58bb6f5b 100644
--- a/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ DESCRIPTION="Arbitrary size floating point math package"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=virtual/perl-Math-Complex-1.390.0
diff --git a/perl-core/Scalar-List-Utils/Scalar-List-Utils-1.460.0.ebuild b/perl-core/Scalar-List-Utils/Scalar-List-Utils-1.460.0.ebuild
index a1784823d94b..87c92e1be3fe 100644
--- a/perl-core/Scalar-List-Utils/Scalar-List-Utils-1.460.0.ebuild
+++ b/perl-core/Scalar-List-Utils/Scalar-List-Utils-1.460.0.ebuild
@@ -11,6 +11,7 @@ DESCRIPTION="Common Scalar and List utility subroutines"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="${RDEPEND}