summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-12-06 11:59:27 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-12-06 12:01:00 +0100
commit346145602ffa362e1c3156f1b869b5ad5c22a6bc (patch)
tree7bc0e602fba015b052a1d0c5753bd185b5954474 /net-wireless/soapyplutosdr
parentsci-libs/kineto: add 0.4.0_p20231031 (diff)
downloadgentoo-346145602ffa362e1c3156f1b869b5ad5c22a6bc.tar.gz
gentoo-346145602ffa362e1c3156f1b869b5ad5c22a6bc.tar.bz2
gentoo-346145602ffa362e1c3156f1b869b5ad5c22a6bc.zip
net-wireless/soapyplutosdr: add 0.2.1_p20220710
Closes: https://bugs.gentoo.org/919318 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'net-wireless/soapyplutosdr')
-rw-r--r--net-wireless/soapyplutosdr/Manifest1
-rw-r--r--net-wireless/soapyplutosdr/soapyplutosdr-0.2.1_p20220710.ebuild27
-rw-r--r--net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild8
3 files changed, 32 insertions, 4 deletions
diff --git a/net-wireless/soapyplutosdr/Manifest b/net-wireless/soapyplutosdr/Manifest
index 4d0ae4a95984..12cf45f42a62 100644
--- a/net-wireless/soapyplutosdr/Manifest
+++ b/net-wireless/soapyplutosdr/Manifest
@@ -1 +1,2 @@
DIST soapyplutosdr-0.2.1.tar.gz 17597 BLAKE2B d5b6205da7aa64406ccf84d198088094c10397ca874925926dfe2ee3134e045c3ab80b68db06ee84448ae8966e2d8edecb2517ef70b10bbddd9681fcbf09385a SHA512 40cc7c83c13f1d81212c5b0b6028d49de6c9e0b4df9e479c5cb577f60a92b415f76e159d45ecf19aad2deac507f7bd779b7cce1f7bc5e6fd2ea9a3f24399dfe7
+DIST soapyplutosdr-0.2.1_p20220710.tar.gz 25233 BLAKE2B b7151f6a00f820edf958006c6ece78e75ad0f5b5b07a232d82dbbf8cf86fa414eed085ee769ecf66fb707dac5d006925791dfd39c1a7fc35f8f887543fe0daf3 SHA512 55757db81d715466148c8376d713783af85ce072036d97ea80b5bd1993fa2180f2f8ca20391d83d1fc5cb6a2ff9977f34d95ddc2beff9ed21282af40b47ea160
diff --git a/net-wireless/soapyplutosdr/soapyplutosdr-0.2.1_p20220710.ebuild b/net-wireless/soapyplutosdr/soapyplutosdr-0.2.1_p20220710.ebuild
new file mode 100644
index 000000000000..254e0ba2adb5
--- /dev/null
+++ b/net-wireless/soapyplutosdr/soapyplutosdr-0.2.1_p20220710.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Soapy SDR plugin for the Pluto SDR"
+HOMEPAGE="https://github.com/pothosware/SoapyPlutoSDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyPlutoSDR.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ COMMIT="b906b27e6820fe44fcc3527cc876771f7dac85d2"
+ SRC_URI="https://github.com/pothosware/SoapyPlutoSDR/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyPlutoSDR-${COMMIT}
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-libs/libiio:=
+ net-libs/libad9361-iio:="
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild b/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
index 813d3574f115..254e0ba2adb5 100644
--- a/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
+++ b/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -12,8 +12,8 @@ if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapyPlutoSDR.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~x86"
- COMMIT="782650597b18f311cc97fbb7c6813539e6adef16"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ COMMIT="b906b27e6820fe44fcc3527cc876771f7dac85d2"
SRC_URI="https://github.com/pothosware/SoapyPlutoSDR/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapyPlutoSDR-${COMMIT}
fi