summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/python-wifi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/python-wifi')
-rw-r--r--net-wireless/python-wifi/Manifest1
-rw-r--r--net-wireless/python-wifi/metadata.xml11
-rw-r--r--net-wireless/python-wifi/python-wifi-0.5.0-r1.ebuild36
-rw-r--r--net-wireless/python-wifi/python-wifi-0.5.0-r3.ebuild34
4 files changed, 82 insertions, 0 deletions
diff --git a/net-wireless/python-wifi/Manifest b/net-wireless/python-wifi/Manifest
new file mode 100644
index 000000000000..1bf83c08e868
--- /dev/null
+++ b/net-wireless/python-wifi/Manifest
@@ -0,0 +1 @@
+DIST python-wifi-0.5.0.tar.bz2 69113 SHA256 3e3f645d37ab20450f60c785cec5f21b330f28a6c46c7c1b0898305dd7a34b26 SHA512 cbbb337b20f60bb28597dc6e3c90b8d20ddee9512cf000ca0107eb01d2bfde1b3047458d1a3f4dc4b9836ae283cbc24792ffb95c4747027896cd6e50a72151d8 WHIRLPOOL d31688208976d8b5e3ea44211fc9e752238723d86aeb3aae5e28ba2e977881cd2bd6be8267dcd1507ee0681fba3aa65d6dfdc8cb84226aef391461e225a37406
diff --git a/net-wireless/python-wifi/metadata.xml b/net-wireless/python-wifi/metadata.xml
new file mode 100644
index 000000000000..bb3d54433065
--- /dev/null
+++ b/net-wireless/python-wifi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">python-wifi.berlios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/python-wifi/python-wifi-0.5.0-r1.ebuild b/net-wireless/python-wifi/python-wifi-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..d57d7a397a1b
--- /dev/null
+++ b/net-wireless/python-wifi/python-wifi-0.5.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Provides r/w access to a wireless network card's capabilities using the Linux Wireless Extensions"
+HOMEPAGE="http://pypi.python.org/pypi/python-wifi https://developer.berlios.de/projects/pythonwifi"
+SRC_URI="mirror://berlios/${PN/-}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+LICENSE="LGPL-2.1 examples? ( GPL-2 )"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
+
+DOCS="docs/AUTHORS docs/BUGS docs/DEVEL.txt docs/TODO"
+PYTHON_MODNAME="pythonwifi"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${P}/
+ doins -r examples || die "no examples"
+ fi
+ rm -rvf "${ED}"/usr/{docs,examples,INSTALL,README} || die
+ mv -v "${ED}"/usr{,/share}/man || die
+}
diff --git a/net-wireless/python-wifi/python-wifi-0.5.0-r3.ebuild b/net-wireless/python-wifi/python-wifi-0.5.0-r3.ebuild
new file mode 100644
index 000000000000..3c8d88d41c99
--- /dev/null
+++ b/net-wireless/python-wifi/python-wifi-0.5.0-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides r/w access to a wireless network card's capabilities using the Linux Wireless Extensions"
+HOMEPAGE="http://pypi.python.org/pypi/python-wifi"
+SRC_URI="mirror://sourceforge/${PN}.berlios/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="LGPL-2.1 examples? ( GPL-2 )"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/AUTHORS docs/BUGS docs/DEVEL.txt docs/TODO )
+
+src_install() {
+ distutils-r1_src_install
+ use examples && dodoc -r examples
+ rm -rv "${ED}"/usr/{docs,examples,INSTALL,README} || die
+ if use examples; then
+ mv -v "${ED}"/usr{,/share}/man || die
+ else
+ rm -rv "${ED}"/usr/man || die
+ fi
+}