summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-03-20 15:16:05 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2022-03-20 15:16:05 +0100
commitf2dedacd6ce7bc65ff0b2993ddf9a33d8286e9f3 (patch)
treefc5d23f9fe546d60e823bf695d2f4c9f5ff3c6fd /net-wireless/nanovna-saver
parentnet-im/cawbird: correct RDEPEND, update xdg caches (diff)
downloadgentoo-f2dedacd6ce7bc65ff0b2993ddf9a33d8286e9f3.tar.gz
gentoo-f2dedacd6ce7bc65ff0b2993ddf9a33d8286e9f3.tar.bz2
gentoo-f2dedacd6ce7bc65ff0b2993ddf9a33d8286e9f3.zip
net-wireless/nanovna-saver: Version bump
Closes: https://bugs.gentoo.org/822234 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'net-wireless/nanovna-saver')
-rw-r--r--net-wireless/nanovna-saver/Manifest1
-rw-r--r--net-wireless/nanovna-saver/files/no-newline-in-description.patch17
-rw-r--r--net-wireless/nanovna-saver/nanovna-saver-0.3.10.ebuild37
3 files changed, 55 insertions, 0 deletions
diff --git a/net-wireless/nanovna-saver/Manifest b/net-wireless/nanovna-saver/Manifest
index 5477bafa3243..e60a61e432eb 100644
--- a/net-wireless/nanovna-saver/Manifest
+++ b/net-wireless/nanovna-saver/Manifest
@@ -1 +1,2 @@
+DIST nanovna-saver-0.3.10.tar.gz 477821 BLAKE2B c41889c1421642c7df55e470b7a45acdf17483203a133d909ca3323150bdf1b712af42c1c28981c8171535fa13dc3573218a4872139f72a447ce29a1f7921b35 SHA512 47a13673aa5639bb3eabbf55a183a19b611144710041a7a4dac4782b4f022f0a316453169a210123c4f26dab1a19af27be37cddcf641d8aecc266396b8fa6eff
DIST nanovna-saver-0.3.8.tar.gz 357896 BLAKE2B bace55c49c55e7389931c9f001e49cf8c0dab895b390e1be94d9f590e8c6352d81ff0ce6029c06211939360c76710c4df919af3e0f41533e1d7d56b75a788d3e SHA512 f560d076eb2ab06e441b0e1cb73cf20318abacc70dc9092ef9e32bac4198922aead8210997c176c774dffe2325407ad66cfbbb0f120f1fb465b84e46b28beed8
diff --git a/net-wireless/nanovna-saver/files/no-newline-in-description.patch b/net-wireless/nanovna-saver/files/no-newline-in-description.patch
new file mode 100644
index 000000000000..ba3fda0e5869
--- /dev/null
+++ b/net-wireless/nanovna-saver/files/no-newline-in-description.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.cfg b/setup.cfg
+index 646e60b..535721f 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -3,11 +3,7 @@ name = NanoVNASaver
+ author = Rune B. Broberg
+ license = GNU GPL V3
+ license_file = LICENSE
+-description =
+- A multiplatform tool to save Touchstone files from the
+- NanoVNA, sweep frequency spans in segments to gain more
+- data points, and generally display and analyze the
+- resulting data.
++description = A multiplatform tool to save Touchstone files from the NanoVNA, sweep frequency spans in segments to gain more data points, and generally display and analyze the resulting data.
+ long_description = file: README.md
+ url = https://github.com/NanoVNA-Saver/nanovna-saver
+ version = attr: NanoVNASaver.About.VERSION
diff --git a/net-wireless/nanovna-saver/nanovna-saver-0.3.10.ebuild b/net-wireless/nanovna-saver/nanovna-saver-0.3.10.ebuild
new file mode 100644
index 000000000000..1270f8f75142
--- /dev/null
+++ b/net-wireless/nanovna-saver/nanovna-saver-0.3.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="tool for reading, displaying and saving data from the NanoVNA"
+HOMEPAGE="https://github.com/mihtjel/nanovna-saver"
+SRC_URI=""
+
+LICENSE="GPL-3+"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mihtjel/nanovna-saver.git"
+else
+ SRC_URI="https://github.com/mihtjel/nanovna-saver/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/no-newline-in-description.patch )
+
+src_prepare() {
+ rm "${S}"/test -R || die
+ distutils-r1_src_prepare
+}