summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-15 09:17:27 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-15 13:39:45 +0200
commit696a0dbf78a138c866dbed69a620342f46bbf879 (patch)
treeebad96ec01d8ad82a79aa151045fa5ead5a1d888 /net-wireless/gnome-bluetooth
parentwww-apps/gitea: remove 1.10.3 (diff)
downloadgentoo-696a0dbf78a138c866dbed69a620342f46bbf879.tar.gz
gentoo-696a0dbf78a138c866dbed69a620342f46bbf879.tar.bz2
gentoo-696a0dbf78a138c866dbed69a620342f46bbf879.zip
net-wireless/gnome-bluetooth: bump to 3.34.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 5a42c0791698..11d47122af43 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1 +1,2 @@
DIST gnome-bluetooth-3.34.0.tar.xz 351232 BLAKE2B 5ed3a2edc4d0a494013c246ce4caa64cc343c08ceeca3fbdc809591c59a59a7e269b35ba2474f38bb9ae1aba7f7b47f2d164c2be49d3e59d1af538a77a7451ab SHA512 25c99f3ac4398b24c08018cdf41a124c94312bc0b1c7202c82918134ddbdea16d6ee0980536cb45deb42ae8fa25b6e86ad21870646235108583831bf5f00926e
+DIST gnome-bluetooth-3.34.1.tar.xz 354568 BLAKE2B 53e0f4d172e12ba1fec8dae476929fadaab2fd0a8e8ac063debbe516f925a3bb04c9000012fc2e143baf00c7bbdd4f2bd31bd64e674c1851e4ec544ab9c058a5 SHA512 3e0080bbeeddc144fdcf6b4f0d59b0885fd5881aee670d2e5dffd4ede9b0f988358ad0e815ba86add8b7fd5e93e1f8fc7bfacd10b8d69606aa569fd67356be08
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.1.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.1.ebuild
new file mode 100644
index 000000000000..af4accb2f528
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson udev xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="gtk-doc +introspection"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+"
+BDEPEND="
+ >=dev-util/meson-0.49.0
+ !net-wireless/bluez-gnome
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicon_update=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! has_version 'sys-auth/consolekit[acl]' && ! has_version 'sys-apps/systemd[acl]' ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}