summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-10-27 13:20:39 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-10-27 13:21:12 -0500
commite13309f0acfcd12f637c16392e18600eaf71bd05 (patch)
tree26784029761f9927c1b719ec13e04586474019f2 /net-vpn
parentapp-emulation/diskimage-builder: drop 3.24.0 (diff)
downloadgentoo-e13309f0acfcd12f637c16392e18600eaf71bd05.tar.gz
gentoo-e13309f0acfcd12f637c16392e18600eaf71bd05.tar.bz2
gentoo-e13309f0acfcd12f637c16392e18600eaf71bd05.zip
net-vpn/tailscale: add 1.32.2
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.32.2.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 979c601aef07..8d368cac10bb 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -8,3 +8,5 @@ DIST tailscale-1.26.2-deps.tar.xz 134312708 BLAKE2B d7a2cafb7c806b01982970dbb1d4
DIST tailscale-1.26.2.tar.gz 1139290 BLAKE2B f9424d91e8a09874941b1a351b0a600e705d117afcf2d60787b1950a295cee5e9e4926034235804824e59c8fe09abd830e2cdfe2b6389134c37ac2f0be6eb82b SHA512 a0d235660b6266d73b415ff1701ba949a7d84cd6a204870f41b16bf66ae27aebf82ffb06a4ec4a695b18c5b3c63f45a990167dc41d617a4718e5e3511daf49a3
DIST tailscale-1.32.0-deps.tar.xz 136965688 BLAKE2B d8d8859c99184d0dee335ff169c88ea86c700a471c92bdd28636a2200c2702174564609707fdca880c2ababa7433eea328a171cb18f1e47498cdfcbcd41e55cc SHA512 5c9a29ac51b80bb1833285b0527f8ae7419b60a205027b9562b162f064f3b772f7757ef9dce1dbc0697b6ec039b91df31c8f18b887ca82323e4be87bfe2e7e88
DIST tailscale-1.32.0.tar.gz 1355487 BLAKE2B 894f42ec967ddce78c93776041285b53c9587b4ef5ca909e9bdebbb590ee6803fb7ec3cd9727c5c8ce7bd0757388c6f1f2a98224b08cdd0f2fd5b86d8c9ceb5b SHA512 a6014102f059b6e88fdb6c5d4228263cc01f03f26c5dc862cfe0b3e0e74d8756e2c854c7916fbfece6295231b4f95363fa2f9664211a6d2a27277e44a6a8cb6b
+DIST tailscale-1.32.2-deps.tar.xz 136970924 BLAKE2B 7fef3626e0ffe2b789a5da3cee0493eb83037a624f71ae8f512b8bfe21cd0965f4c94abd1423f6f57a5f3467d049d19ee50545c39cdff8d00172c35bded0daae SHA512 8b3fe5ec443341633c4c1619d63462051cf4f39dfc4fe20631dffac075b5ee27e6902d3f0a04604f87dd0cf581bc1ddb6585c6236ec4a3fc2d5241a8d0c06ebb
+DIST tailscale-1.32.2.tar.gz 1359648 BLAKE2B 91380e61c263c8f46f4a2b74aac5b103a6d8fcf26dc144eb24ffc8ec01fcc680bd5229ca998ec6ae2cba5fedfaf761dfcb3c498f5fe7edfe6e2931ddcb8d6fff SHA512 8f4d898e3b4503d9988124333fee2621e6d048eb7df60a5eff60c328b338432c7b22245ff0cbf0e5214154eccdac2bed652ea924d56ed1d071dd6345fdf1a477
diff --git a/net-vpn/tailscale/tailscale-1.32.2.ebuild b/net-vpn/tailscale/tailscale-1.32.2.ebuild
new file mode 100644
index 000000000000..0694acc85291
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.32.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="1.32"
+VERSION_SHORT="1.32.2"
+VERSION_LONG="1.32.2-t54e8fa172"
+VERSION_GIT_HASH="54e8fa172b725b354598daaa7007d261fd932d10"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}