summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPuqns67 <me@puqns67.icu>2024-08-25 23:05:10 +0800
committerZac Medico <zmedico@gentoo.org>2024-08-25 18:06:09 -0700
commitda1c40b1eeaa97c850d38c17ffc176514e1eecbe (patch)
tree785512ae2e88ed628e9d6b42ff2a5bbfa9cd4c88 /net-vpn
parentdev-libs/libtracefs: use https:// instead of git:// for cloning, fix HOMEPAGE (diff)
downloadgentoo-da1c40b1eeaa97c850d38c17ffc176514e1eecbe.tar.gz
gentoo-da1c40b1eeaa97c850d38c17ffc176514e1eecbe.tar.bz2
gentoo-da1c40b1eeaa97c850d38c17ffc176514e1eecbe.zip
net-vpn/frp: add 0.60.0
Signed-off-by: Puqns67 <me@puqns67.icu> Closes: https://github.com/gentoo/gentoo/pull/38286 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/frp/Manifest2
-rw-r--r--net-vpn/frp/frp-0.60.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/net-vpn/frp/Manifest b/net-vpn/frp/Manifest
index fc780a5df065..4a66e7bda912 100644
--- a/net-vpn/frp/Manifest
+++ b/net-vpn/frp/Manifest
@@ -2,3 +2,5 @@ DIST frp-0.56.0-deps.tar.xz 2890568 BLAKE2B cabeeba66d4fa94ff95637020178310c984b
DIST frp-0.56.0.tar.gz 1080201 BLAKE2B 493e8b21aab6d5fae2d762eafba7d94de59394e9c4cb3c3dfce2bd8b5a0d0fcca6ef471917e8257022e079bececf34e910fe3b6bc845753862da59a1d00ca20c SHA512 883dce220aa78296f2b7eb9d64b3d1598bc2df436c52a48bc813d725a6f8fa43028359b0507bf4a586a29f4739310474047abfefd46249c0c9942990ceac0e2d
DIST frp-0.58.1-deps.tar.xz 2916740 BLAKE2B 49256c40ca359a5b76a92e2999e3a5a3ca4899f71e4804544296ee71fa6c079f563b1892195243e9e8792c72c445f779fb5a32b1cc5c4ebca9265d88808072e3 SHA512 3295e0e6b5a7ace8c5af1dd9e15ffb893930c0f03755e8de46dfbca2272747b95d8e58f4034f4fa2c44896c5036654b3c805a6d3dd0d39299996335330d28d07
DIST frp-0.58.1.tar.gz 1081317 BLAKE2B e5d897a9d866df1075c9fb397f1cbcf23efb738fd89e58bce4fba5abce23d9cb6c826b50d4cda52b3fa40a6194003a51c6209f2d4aef43d9dc62f08b51a776a7 SHA512 809e86e9cd2cb67ae338b2584c0c8f5d4f01104cc7725826743f48eb5c893bce9cd678bcd90e04953bb6bfc6523fcf400c6bc1bdf03ff335666b05af5e0c4b55
+DIST frp-0.60.0-vendor.tar.xz 2816520 BLAKE2B 3f58f108c1dc563d73d119293d9cbcb181059c24bb58731f5d6d870a320982c976c8a0938ff0442bd21ffd0bb86218aaa20f1b382fb7a045422aaea411ad3557 SHA512 9825d39cd4bce25ad796b3ac817e690ca41daf9f028ac4e88aa43b4e295d20f9ede57a1be8933efca00a512ff238f8e34a85f24a4b56f9c52cf40aa1f26118f9
+DIST frp-0.60.0.tar.gz 1073862 BLAKE2B c6169818bbca656d44bc945c70b73474a4f427bd123fa7a546285fb63d3a156dc90d7fa1d46f2ba4ae971281e546fb43a217ad2527b7bd20a402810cb356d7ac SHA512 4c86b91a28b58ce5b681e5f8c886efd57a41fb6ac92606facce0b6f6f6cbd6cf6f789209252455bc6bc6a3ad043f2470040ac84b893926653cc036b40907e60c
diff --git a/net-vpn/frp/frp-0.60.0.ebuild b/net-vpn/frp/frp-0.60.0.ebuild
new file mode 100644
index 000000000000..994a8b5d4b28
--- /dev/null
+++ b/net-vpn/frp/frp-0.60.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd shell-completion
+
+DESCRIPTION="A reverse proxy that exposes a server behind a NAT or firewall to the internet"
+HOMEPAGE="https://github.com/fatedier/frp"
+SRC_URI="https://github.com/fatedier/frp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/Puqns67/gentoo-deps/releases/download/${P}/${P}-vendor.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv"
+IUSE="+client +server"
+REQUIRED_USE="|| ( client server )"
+BDEPEND=">=dev-lang/go-1.22"
+
+src_compile() {
+ mkdir -pv comp || die
+
+ if use client; then
+ ego build -trimpath -ldflags "-s -w" -tags frpc -o frpc ./cmd/frpc
+ ./frpc completion bash > comp/frpc || die
+ ./frpc completion fish > comp/frpc.fish || die
+ ./frpc completion zsh > comp/_frpc || die
+ fi
+
+ if use server; then
+ ego build -trimpath -ldflags "-s -w" -tags frps -o frps ./cmd/frps
+ ./frps completion bash > comp/frps || die
+ ./frps completion fish > comp/frps.fish || die
+ ./frps completion zsh > comp/_frps || die
+ fi
+}
+
+src_install() {
+ _install() {
+ # Install binary file
+ dobin "${1}"
+
+ # Install completion files
+ dobashcomp "${S}/comp/${1}"
+ dofishcomp "${S}/comp/${1}.fish"
+ dozshcomp "${S}/comp/_${1}"
+
+ # Install systemd services
+ systemd_dounit "${FILESDIR}/${1}.service"
+ systemd_newunit "${FILESDIR}/${1}_at_.service" "${1}@.service"
+
+ # Install config files
+ insinto "/etc/${PN}"
+ newins "${S}/conf/${1}.toml" "${1}.toml.example"
+ newins "${S}/conf/${1}_full_example.toml" "${1}_full.toml.example"
+ }
+
+ if use client; then
+ _install frpc
+ fi
+
+ if use server; then
+ _install frps
+ fi
+}