summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-03 00:06:40 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-03 00:06:40 -0400
commitb4e4a9c2906867a41c86e83838c88ad9f213064f (patch)
tree9c0417e569a930e21a2b90e8e14235d820491897 /net-vpn
parentnet-vpn/openconnect: cleanup ebuild (diff)
downloadgentoo-b4e4a9c2906867a41c86e83838c88ad9f213064f.tar.gz
gentoo-b4e4a9c2906867a41c86e83838c88ad9f213064f.tar.bz2
gentoo-b4e4a9c2906867a41c86e83838c88ad9f213064f.zip
net-vpn/openconnect: fix tests to work with ocserv installed
Package-Manager: Portage-2.3.96_p4, Repoman-2.3.22_p1 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openconnect/openconnect-8.06.ebuild18
-rw-r--r--net-vpn/openconnect/openconnect-9999.ebuild18
2 files changed, 32 insertions, 4 deletions
diff --git a/net-vpn/openconnect/openconnect-8.06.ebuild b/net-vpn/openconnect/openconnect-8.06.ebuild
index 45d091c8dc39..611910059703 100644
--- a/net-vpn/openconnect/openconnect-8.06.ebuild
+++ b/net-vpn/openconnect/openconnect-8.06.ebuild
@@ -90,9 +90,9 @@ src_configure() {
addwrite /run/netns
local myconf=(
- --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
- $(use_enable static-libs static)
+ --disable-dsa-tests
$(use_enable nls)
+ $(use_enable static-libs static)
$(use_with !gnutls openssl)
$(use_with gnutls)
$(use_with libproxy)
@@ -100,12 +100,26 @@ src_configure() {
$(use_with gssapi)
$(use_with smartcard libpcsclite)
$(use_with stoken)
+ --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
--without-java
)
econf "${myconf[@]}"
}
+src_test() {
+ local charset
+ for charset in UTF-8 ISO8859-2; do
+ if [[ $(LC_ALL=cs_CZ.${charset} locale charmap 2>/dev/null) != ${charset} ]]; then
+ # If we don't have valid cs_CZ locale data, auth-nonascii will fail.
+ # Force a test skip by exiting with status 77.
+ sed -i -e '2i exit 77' tests/auth-nonascii || die
+ break
+ fi
+ done
+ default
+}
+
src_install() {
default
diff --git a/net-vpn/openconnect/openconnect-9999.ebuild b/net-vpn/openconnect/openconnect-9999.ebuild
index 45d091c8dc39..611910059703 100644
--- a/net-vpn/openconnect/openconnect-9999.ebuild
+++ b/net-vpn/openconnect/openconnect-9999.ebuild
@@ -90,9 +90,9 @@ src_configure() {
addwrite /run/netns
local myconf=(
- --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
- $(use_enable static-libs static)
+ --disable-dsa-tests
$(use_enable nls)
+ $(use_enable static-libs static)
$(use_with !gnutls openssl)
$(use_with gnutls)
$(use_with libproxy)
@@ -100,12 +100,26 @@ src_configure() {
$(use_with gssapi)
$(use_with smartcard libpcsclite)
$(use_with stoken)
+ --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
--without-java
)
econf "${myconf[@]}"
}
+src_test() {
+ local charset
+ for charset in UTF-8 ISO8859-2; do
+ if [[ $(LC_ALL=cs_CZ.${charset} locale charmap 2>/dev/null) != ${charset} ]]; then
+ # If we don't have valid cs_CZ locale data, auth-nonascii will fail.
+ # Force a test skip by exiting with status 77.
+ sed -i -e '2i exit 77' tests/auth-nonascii || die
+ break
+ fi
+ done
+ default
+}
+
src_install() {
default