summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-08 08:13:29 +0000
committerSam James <sam@gentoo.org>2022-11-08 08:30:10 +0000
commit6d4776e500c5fc4859a9cbd26e52e4cfc3ee065a (patch)
tree406a9cd73ff5baa2e10ab31950910aac7b803a86 /net-vpn
parentsys-devel/gcc: add 13.0.0_pre20221106 (diff)
downloadgentoo-6d4776e500c5fc4859a9cbd26e52e4cfc3ee065a.tar.gz
gentoo-6d4776e500c5fc4859a9cbd26e52e4cfc3ee065a.tar.bz2
gentoo-6d4776e500c5fc4859a9cbd26e52e4cfc3ee065a.zip
net-vpn/openfortivpn: add 1.19.0
Bug: https://bugs.gentoo.org/880313 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index 10982443f13e..a16b4bf5766a 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1,2 +1,3 @@
DIST openfortivpn-1.17.1.tar.gz 167127 BLAKE2B 4b8f9fb82c4f7c8ffcecf9f14c576d73c999712b7b183b74f9d60d59c67017080a3d16d95ae74fa7f07188e9b28bdf8384f9b41ea7a4ce8e24813044d27216b9 SHA512 9d8be1043833bfa0eba6e4032c767946e88d079d329f8039964ea659c4dffb54a5a3b2a6431b66bd86590eaca8bf598a110c368714ecd7ea00312ee97f329085
DIST openfortivpn-1.18.0.tar.gz 169141 BLAKE2B 28ac333bd1aa5b7be1e8cfb5a3dd968f2852c445d86050db2eb3161a6b7cd7f765607a3c8ec8bb8c65ba7d8340d8f526f08703ab6df9ab4f7a9f2d2666d767df SHA512 77a1c102e8bd6dfe5a86fe375449a3dd0253634d555dc084bd188a97d855afdd16f71b5b25fd6b737381c7da332228e22e3519d5a2b1d49099c56bc7c21e6088
+DIST openfortivpn-1.19.0.tar.gz 168962 BLAKE2B f2cff6f89a0662aca5911f6c3ef5953181383d4a66a41df83916c551338f07364436a174de39874cb654d6538955ac5d0a57a875facf2cc9b8c8a27a48df7fbf SHA512 4f4179178cbf2fc03ddebdfd4197c03a7108ecfa5216d5f11d80b2e3b840816f0a9a59714f58ecdcf966b76eb9b459e0bf78901940120ed1aa1cf69021385a53
diff --git a/net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild b/net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild
new file mode 100644
index 000000000000..f9a5078e5045
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:0=
+ net-dialup/ppp
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}/systemd_substitute_bin_and_sysconfig_dirs.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}