summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-10-01 23:42:31 -0400
committerMike Gilbert <floppym@gentoo.org>2021-10-02 02:00:07 -0400
commit57a243e8d4179253b2fea231a04e35e3c569be3b (patch)
tree8bc12bb61c80ecd811144192bb3bd16db700e8c4 /net-vpn
parentdev-ml/ppxlib: add 0.23.0 (diff)
downloadgentoo-57a243e8d4179253b2fea231a04e35e3c569be3b.tar.gz
gentoo-57a243e8d4179253b2fea231a04e35e3c569be3b.tar.bz2
gentoo-57a243e8d4179253b2fea231a04e35e3c569be3b.zip
net-vpn/vpnc-scripts: initial import
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/vpnc-scripts/Manifest1
-rw-r--r--net-vpn/vpnc-scripts/metadata.xml8
-rw-r--r--net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild23
-rw-r--r--net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild23
4 files changed, 55 insertions, 0 deletions
diff --git a/net-vpn/vpnc-scripts/Manifest b/net-vpn/vpnc-scripts/Manifest
new file mode 100644
index 000000000000..de68088215d6
--- /dev/null
+++ b/net-vpn/vpnc-scripts/Manifest
@@ -0,0 +1 @@
+DIST vpnc-scripts-20210402.tar.gz 39925 BLAKE2B 2bc8a274773e51ba48e402588fdf5b51d20360f610afe5608f91dfe2466644b68d891a60c27e4c6938b4ed5da1f193ddb7a8ac955c8f02e6bf91437dc5c47620 SHA512 5f9fc5ab1a5a2607f807700536c4a8e71c551052e72979c1cdd02b15906615be33a297b873b0806f269e51645f10f1c02a7acfed2501148bfa2797250582920d
diff --git a/net-vpn/vpnc-scripts/metadata.xml b/net-vpn/vpnc-scripts/metadata.xml
new file mode 100644
index 000000000000..de09ffd8b089
--- /dev/null
+++ b/net-vpn/vpnc-scripts/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild b/net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild
new file mode 100644
index 000000000000..83fa0467d1d8
--- /dev/null
+++ b/net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/openconnect/vpnc-scripts.git"
+else
+ SRC_URI="ftp://ftp.infradead.org/pub/vpnc-scripts/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Connect scripts for use with vpnc and openconnect (and similar clients)"
+HOMEPAGE="https://gitlab.com/openconnect/vpnc-scripts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+src_install() {
+ exeinto /etc/vpnc-scripts
+ doexe vpnc-script{,-{ptrtd,sshd}}
+}
diff --git a/net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild b/net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild
new file mode 100644
index 000000000000..83fa0467d1d8
--- /dev/null
+++ b/net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/openconnect/vpnc-scripts.git"
+else
+ SRC_URI="ftp://ftp.infradead.org/pub/vpnc-scripts/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Connect scripts for use with vpnc and openconnect (and similar clients)"
+HOMEPAGE="https://gitlab.com/openconnect/vpnc-scripts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+src_install() {
+ exeinto /etc/vpnc-scripts
+ doexe vpnc-script{,-{ptrtd,sshd}}
+}